Simucube 2 pro suddenly won’t connect to pc anymore

Haven’t touched my rig in a while and came back to give it a crack and my wheelbase won’t connect anymore. It turns on and beeps and there’s a blue light on the back but it won’t connect to my pc and is not recognised by true drive.

I installed new version of true drive still won’t work, took it off my rig and tried other power outlets with a new pc with a fresh install of true drive and the error message usb device not recognised pops up on the pc.

Here is the error message.

Had no issues with my wheelbase until now. Pretty sure it’s first gen simucube 2 pro with 2 power supplies.

Any assistance with resolving my issue would be greatly appreciated.

Kind regards, Alex

As a first test, change the usb cable with a known working cable, and also try a few different ports on your pc. Whilst your usb cable power rails seems ok, there might be a broken data-line.

Tried working usb cable, same issue

Do you have a laptop you can connect it to? And make sure the correct version True Drive is used to talk to the device - if you use the latest version True Drive, it should prompt you to do a FW upgrade also….

PS: I see you did try on a different PC. so that only leaves 2 possibilities, but most liklyscenario is the usb interface might be kaput. Let’s see what Mika says, but you will probably have to contact your reseller to proceed with RMA.