Simucube 2 Pro suddenly inconsistent FFB

I fired up my rig yesterday for the first time in almost a week. Last time I used it was to try Kart Kraft again. Before that it was mainly AC through content manager, ACC, and probably 90% iRacing. I have been using irFFB for months and it’s been fantastic. Smooth as butter FFB, solid force and no issues.

When I fired up AC it felt off. Like it was only getting force updates like 2-3 times a second. Meaning the force when it was on was strong and no fade. However it would some times feel like less force in transition from left to right or slides.

So I figured it was a bad car and just went to iracing. BMW GT3 to be precise which I knew had one of the better feel for GT. Out of the pits and it felt very very notchy.

Went back and tried Indycar and same. Very notchy.

Tried a few things like going back a version of true drive, trying with and without irFFB. Went to try ACC. While it feels slightly different in each sim, they are all off and not as smooth as before.

I thought bad USB cable but that was not it.

Can someone please help point me in right direction? I do have a ticket in with Granite so I don’t want to try anything too crazy, but does this seem familiar to anyone? I had this thing nearly 2 years. Never a hint of an issue. Now it feels like it broke on inside and I didn’t think that was possible.

Thanks so much.


Sometimes even a windows update could be the culprit. Is it possible for you to test your base with another computer ?

No not really. Working with Mika on support ticket, but I am still just confused by what is going on.

Also out of trying to understand, what would a Windows Update do to cause something like this?

Just a latest example

Thank you sir. Will check this out.

This update should be in Windows update history would it not?

I guess but check my 2nd link , someone gives guidelines how to disable the service i think. It could be irrelevant but windows updates tend to mess things up a lot

I think that update from Microsoft just messed up those wheel bases and specifically Thrustmaster, that have a dedicated device driver that is accessed via the Windows.Gaming.Input API.

Noted. Will reply to ticket about other options Mika.

that is why i said that this specific update could be irrelevant with Bryan’s problem. But updates do tend to brake things that’s why i proposed to try with another computer. But i am sure that the support will figure it out.

Thanks Loukas, I will wait but I have my partners PC ready if needed. I just want to work through some of this first as I would need to install iRacing or something else on it, and it is a bit of a pain to do if there is something else.

Also hers is more updated than mine (on Windows 11) so just do want to introduce another variable yet :slight_smile:

I’ll keep this thread updated as I think there could be value in it for someone else.

1 Like

For reference I have tried:

  • Reverting to an older version of true drive (both most recent, and one from last year). No difference (did that before sending ticket)
  • Tried different USB ports, and checked the cable, all fine (and never had a disconnect, wheel was always providing input to the game, just the force wonky)
  • Had me encoder recalibration (Ctrl-E) and did not work
  • Had me introduce desktop centering force to see if that had similar effect and that was smooth as butter at all percentages

Last windows update was (aside from anti-virus updates) March 15, and it worked fine since then.

1 Like

Just for the community, as I updated my ticket as well.

I tried on another PC. Similar issue (hard to get settings perfect for back to back, likewise no irFFB which I would have blamed directly if not for AC and ACC issues :))

Two things I noticed where I only felt curb and grass effects when wheel was almost straight (like 5 deg left or right max). After that all those effects went kind of numb, and I mostly felt a centering force.

When I did my calibration I was able to push past the bump stop pretty easy. Like it was a firm line point where I could feel it, but even on hard it was feeling very soft and I could go past pretty easily where I couldn’t before.

I am assuming hardward now but hoping someone has something :slight_smile:

This would indicate that the wheel is not in high torque mode, or that simulator is outputting force that is clipping all the time.

Further update:

I tried today with ACC on the 1.9 Update and I feel it more there now as well.

Also tried testing the steering in iRacing, ACC, and AC, but looking at the steering in options to see if it is smooth. It does not appear to be in all cases. Like it will stop updating the movement for a few degrees then carry on.