Simucube 2 Pro stuck on waiting for drive to get ready

Started yesterday, device no longer responds to input. I have a separate button setup so the Simucube 2 Pro is only dealing with steering motion. Device arrived Jan of 2021 so is only a year old.

Normally the wheel goes solid, but since yesterday this isn’t the case. Tried all the normal basics (off and on again, different cables, different USB ports, etc…). Also updated to latest software and firmware and the same problem exists.

Is this a known issue? Is there a solution to this?

My guess would be that you need to check out your E-stop and make sure that’s functioning correctly.

Check this thread for some tips and guidance.

Is this a Pro with single or dual PSU setup?

Dual PSU setup. Unplugged both and re-plugged them to clean connections a little.

@EsxPaul I checked E-Stop and it’s correctly registering pressed and released statuses.

Please do the power button wire check as described on the pdf available via support pages:

Will try that over the weekend. Thanks Mika

Shouldn’t user check that voltage from both PSU is about equal before crack opening the case?
What is acceptable tolerance?

The revision 1 Pro will start just fine with only one PSU connnected. As the input voltage is measured only after load balancing resistors, there is no way to detect if both PSUs are plugged in. The problems that could happen in rare cases only happen in high torque situations while driving, not at device startup.

I was referring to situation of PSUs voltage mismatch, remember we had few cases reported here requiring users to replace them. Should user check voltage to see if this is the same issue?

no, “waiting for drive to get ready” cannot be a psu voltage mismatch issue, if it happens on device start while user is not moving the wheel at all.

So moving those wires out from under the phase wires seems to have done the trick.

Thanks guys.


So things have developed further.

Unscrewing the backplate and moving the wires only works for one instance of turning the device on.

After that it goes back to the same issue when trying to turn the unit on for a 2nd or subsequent time.

Any idea why?

Strange. We did make the noise calibration more lenient some time last year.

Yeah it does seem strange. Could a bad earth cause the issue?

Yes, poor grounding can also be the cause of this issue. Is the unit on a grounded socket?

It is on a grounded socket, but I’ll change socket in case the socket itself has poor grounding. Not exactly the newest house as far as technical innovation goes :smiley:

Something else I noticed is a greater EMF interference with my wheel’s buttons. It’s never had a well shielded cable/controller but now the interference is bad enough to stop all bar 2 buttons and the shift paddles working.

This is definitely a new development too as it hasn’t happened since March '21 until my first report on here.

Just got a UPS and Wheelbase fired up just fine with the 2021.12 driver/firmware/Truedrive.

Updated to the latest 2022.5 driverr/firmware/Truedrive and now it does the 0.00 / ???.?? dance again. Doesn’t turn on again.

Tried restarting PC and all manner of disabling power and trying to trick the unit into starting again. No dice. FYI using an APC 900W/1600vA UPS for purely the wheelbase.

It is very likely that the UPS has worse grounding and more interference than mains AC. There is no reason to use a UPS for wheel base.

Well been through everything I can. Still having the detection problem.

It’s back on the main power board instead of UPS.

If the wheel is in high torque mode, it detects just fine on a PC restart. If total power was lost (defaults to low torque mode) then it refuses to register with Truedrive still. Truedrive version is 2022.7.

Prior to the power being tested and fixed up, I could trick it into detecting by connecting only one of the two power bricks, then connecting the 2nd once it detected. However that no longer works. Now it’s just a random chance it’ll detect on PC restart.

Any ideas on how to solve this?