Simucube 2 Pro — Rotates on startup and not functioning properly

2 Months ago I got the Simucube 2 Pro and it was working fine. Since today I got the following problem(s):

— When enabling High Torque the SC2 moves left and right on it’s own.
— Software is glitching and crashing in a strange way and can’t read the rotation of the SC2 properly
— Sometimes it doesn’t detect the SC2 when power on

I tried upgrading and downgrading the software and rebooting the SC2 Pro and deleting profiles but nothing seems to help.

Is there something else I can do to fix this problem or do I need to contact GPerformance (where I purchased from) to get a replacement or something?


  1. Create a new profile, and make it as default profile. Then save settings to Simucube. Seems like the default profile has somehow gotten corrupted.
  2. Power-cycle the device. Other than the left-right movement, it should work OK.
  3. hit CTRL-E in True Drive to re-enable the absolute encoder mode to not have the movement at power-on.

Hi Mika,

Thank you so much for the quick reply! this solved the problems and the Simucube works as if brand new!

Kind regards and have a nice weekend

Mika, is that Ctrl-E shortcut available on all units?
What does it do exactly, and are there any concerns to have it easily accesible in user facing app where it can be accidentally triggered?
And if it’s a feature, should it be documented in User’s Guide.

1 Like

Its a service feature, that disables absolute encoder, tells the servo drive to reboot (it gets new calibration value for the encoder), and saves that calibration value to be used again by enabling absolute encoder mode, and saves servo drive settings and then commands servo drive to again reboot.

Its not documented because its a service feature and that users would start to use it for no reason, trying to somehow optimize their encoder calibration which is not of any use if there is no real reason to do it.

Just hitting the key combination does not actually initiate anything,though. It presents a menu for doing it.


This kind of users probably never read the manuals anyway.
Having it in “Troubleshooting Instruction” section could have saved OP trouble of waiting for someone from GD to respond with the solution and let him unblock himself.
If not User’s Manual at least in Service Manuals, along with other missing things like FW downgrade instruction.


That would loose us the ability to track frequency on any issues with the encoders - loss of calibration, etc. It is a support tool so that we do not have to work with even more complex debug interface via remote support session.

If it ever becomes a “popular issue” that users would need help with, then we would document it. For support, we have gotten less than a handful of support requests where there has been help from this feature. Mainly, we use it ourselves to get development firmwares iniatialized to proper state at the office :slight_smile:


Hi Mika, this rotate on startup ‘issue’ came back again. But in the latest software the CTRL-E shortcut does nothing anymore. Is this service feature disappeared? or how can I fix it again? Thanks!

Its interesting, something funny is going on if that keeps happening. But CTRL-E is still included in the latest releases, make sure the Paddock is not capturing it somehow.

1 Like

Thanks for the quick response again, I think another application prevented the shortcut to work because after closing all applications the shortcut worked again. After re-enabling the absolute encoder the wheel rotation on startup stopped again.

Curious as to what causes it. it’s happened 3 times now, no problem for me, but could something in my setup or how I use the device affect that? I use it everyday for multiple hours. I think it only happens when I switch to another profile or play with the settings (then I notice it the next day when I’m booting the device again, but then again this happens not always so a pattern is hard to find).

hi my simucube 2 pro has done the same problem left right.
I have searched for a long time on the web and YouTube.

I found this post how to reset your Simucube 2 in the program True Drive but CTRL-E.

it was not easy to find, it took me about 14 days to find.
is it not possible to update the manual for the simucube products. :grinende: :grinende: :grinende: :grinende: :grinende: :grinende:

The encoder recalibration is not any kind of reset of the device. We are still investigating why it seems that some devices forget the calibration and resort to doing it on each device startup instead.

simucube 2 pro
Manufactured: 2022-03-31
H.S. Code: 95045000
Serial: 16441
if it can help you.

hope you find the error at some point.
a really nice day to you all.

:grinende: :grinende: :grinende: :grinende: :grinende: :grinende:

I am having the same left/right rotation issue on power up with my Simucube 2 Ultimate, I noticed it after a True Drive and Firmware update and assumed it was a change and normal. Do you recommend I try this Control-E procedure as well?

It doesn’t affect driving feel, but if the left/right calibration routine is bothering you, you can do the recalibration via the CTRL-E wizard.

It doesn’t bother me at all, thanks for the reply.