Simucube 2 Pro disconnecting while racing

I have had this wheel over a year and a half now and through many different True Drive updates it still exists that when racing I will get the FFB disconnecting followed by beeps then reconnecting. It happens mostly mid corners or when bumping with other cars. I have tried various settings in True Drive to vary the FFB but it persists.

In the last 3 to 6 months I have bought and installed USB hubs from 4 different brands. The latest I am now using is the Startech PEXUSB3S44V with 4 channels separately powered with 5Gb/s bandwidth each, It is highly recommended by many sim racing and VR people, including @phillip.vanrensburg on this forum.

It was an expensive option at $149 Australian and unfortunately has not solved this issue at all. I have now wasted quite a sum of money including also purchasing 3 different high quality USB cables and additional Ferrite chokes to minimise EMI.

I would really appreciate any other ideas as to what may be the answer, or have I got a rare SC2Pro with some faulty control board in it ? I don’t know the answer but I am all out of solutions and answers.

To make matters worse the latest True Drive software is now constantly turning off High Torque after a few minutes of inactivity, I play Assetto Corsa a lot and invariably it happens just when I am perusing tracks & cars and I forget about it until inside a race again so have to pause or exit and re-enable high torque, frustrating. Is there a setting somewhere to increase the timing of when this safety feature kicks in ? If not please add this in the next software release.

My old Accuforce Pro was not as detailed or powerful as this wheel but I am really missing it for the fact it was reliable and never had any of the above issues. I really hope the Simucube company people who read these forums do not just dismiss this as I wonder do they think this is imagined and/or something wrong with the user PC and cannot possible be their hardware ? I am not the only user experiencing this issue and now after replacing many components and reinstalling Win10 Pro several times I feel confident my PC is working correctly but the SC2Pro is not, would love to be proven wrong as I simply want to race and not worry about constant disconnects.

My specs :- Asus TUF Gaming X570 wifi plus with latest Bios and drivers, AMD 5900X Cpu, 16gb DDR4 3600 CL16 Ram, Nvidia 3090 Gpu. I run Simracing Studio 2.0 for my motion system actuators, grounded and shielded + EMI protected with Ferrite chokes and metal enclosure. I also run VR headsets, Reverb G2 and Pimax 8KX.

OS is Win10 Pro, very minimalist software install of only sim racing required programs and sim race titles :- AMS2, Assetto Corsa, AC Competizione, RaceRoom RE, rFactor2, KartKraft and Project Cars 2. Only major race sim I do not use is iRacing.


Hi Blanes! Sometimes, I miss the AccuForce, too. SC4 is amazing for its tuning options and versatility.

Regarding the disconnect issues: what MoBo does your system use?

I ask because I my previous system had frequent USB issues, and like you, I tried many ways to address it over a couple of years. In the end, I moved to a new MoBo and that was the best solution.

Through my research, I found that certain MoBo architecture were manufactured with an internal design flaw related to USB function (board manufacturer denies this). While I was able to find work-a-rounds for some disconnect issues, they were mostly just temporary “band-aid” fixes.

1 Like

Hey Dean, nice to talk with you after very long time ! Yeah I have an Asus TUF Gaming X570 wifi plus Mobo and there was talk couple years back that the original chipset Bios had usb issues.

Since that time it has undergone progressive bios updates to address the USB issues and in my experience with it I have no problems with any other USB device except SC2 Pro.

You may be right but it seems specific to this wheel and there are reports from other SC2pro users scattered around forums. I am not sure I want to go down the path of looking for a replacement mobo because I like the AMD cpu and in all other aspects of use I find it a great system. The Startech USB hub should be bypassing any mobo issues in any case being a 5gb dedicated channel in PCIE x16 slot and certainly seems to have the horsepower to handle a direct drive wheel. As much as I do not want to in the end I probably will have to sell this wheel and try another.

Anyway hope you are well and obviously still enjoying sim racing …
Cheers mate :wink:

Nice talking to you again. Yep, still Sim-racing although, I seem to have a bit less time to enjoy it lately.
My son has my old AccuForce and I may swap with him sometime, just to re-experience all it has to offer. It seems we learn new tricks with every system, and it might be fun to apply that to the AccuForce.

I’ve had my share of hardware issues to be sorted over the years. Nothing ruins a play-session like usb disconnects. My Wacom drawing tablet does cause usb issues, though. I have to unplug that when not in use, as it constantly disconnects / reconnects. New drivers don’t seem to help.

It sounds like you have things sorted with your PC / system. I wish you all the best, whichever way you go.


1 Like

Is it 2 PSU unit, may be power output mismatches between two, causing these issues under load.

Hi Andrew, thanks for the suggestion. I actually have the 2nd version Sc2Pro with single power brick.

Perhaps I can check the power output with a multimeter ? I did not do that yet.

Yep, definitely check out PSU, could be defective, you are not using any UPS in between by any chance, do you?

This sort of sounds a little like the hands free detection kicking in but I have a feeling someone would have mentioned that earlier…

It is also possible that you could have a bad PSU which will underplot on heavy loading… This can come from the dual unit mismatch but can also happen from a single unit going bad.

Another yes would be to run the SC2 through a USB 2.0 port on your machine… NOW the issue here is it may not be connected to the outside of your case but your Motherboard will usually have a header pin location for access… A port output spot is pretty easy to find and attach…

just a random one found…

these are really the only things I can think of that could be causing that… another might be a downgrade in the firmware could possibly help to one of the earlier stable versions.

No ups on my system and many different usb options already investigated. I had never considered the possibility the power brick could be faulty as the disconnects have been apparent since I bought the sc2pro new. I always thought it must be a problem with usb connection.

I haven’t tested it yet as I need a new multimeter. What power readings should it be outputting ? And would a fault still be covered under warranty ?

You can read a story about R2 PSU here.
The original SC2 R1 had 2x280W Meanwell PSUs, the replacement is from Phihong and officially certified by maker for 300W only although GD claims it can deliver 450W.
What you describe sounds like it’s falling short under higher load and causing these interruptions. I am sure if GD can somehow confirm it is PSU, they will send you a replacement, unfortunately this particular PSU is not off the shelf and had some modifications done for SC by manufacturers, so you can’t just buy it.
R1 Meanwell PSUs on the other hand are standard.

Thanks Andrew, what you explained does make sense but how to fault check this power supply to determine is that the problem ?

My wheel has suffered these exact same disconnects ever since I received the sc2pro new, but I guess it may have come from the factory with a faulty component that was not picked up during QA as it mostly performs well. I just never had considered the power supply as the source of the problem.

Do you know what is the warranty period of sc2pro and should I contact the GD company by email or just through this forum ?

I really appreciate the suggestions & advice here … great community !

Start by submitting RMA request here
Meanwhile, try to drop max torque in TD and increase FFB gain in games, in most sims it should cause signal clip before taxing PSU too much.

Okay thanks, actually I have never run my sc2pro any higher than around 14 to 16nm and I did do some tests with it down around 8 to 10nm about a year ago. The disco’s continued in the same way despite the lower power … does that tell us anything ?

Do you have other PC or laptop to borrow, that would rule out MB USB issues, I understand that you have separate PCI-E USB card, but mobo can still play some role here?
As with any technical issue, it’s better to leave it to professionals, GD support in this case, fact that they are closed for summer “holidays” just leaving customers up in the air IMHO is not acceptable for any serious business. Try to ping your dealer as well, that’s what GD would advise anyway.
Hope your issue will be solved in a reasonable time.

Thanks Andrew, Unfortunately I do not have any other pc to connect to.
I am in Australia and purchased from a Murray Motorsports, Ireland on 19 March 2021, 16 months ago now and there were no other options to buy locally back then.

I could contact them but being they are so far away I guess it would be difficult for them to offer much support. I will put in a support ticket though. I looked at the power plug to try read the output but there is 6 pins and I do not want to go poking a multimeter in there without knowing what pins and how much the reading should be.

I am sorry …if this has been mentioned but the 1 single thing you need to do is try your base on another PC …to make sure it’s actually the base …then work from there