simucube 2 pro disconnected

I have had the problem that the true drive no longer recognizes my simucube 2 pro base. I bought the base 2 weeks ago. Usb is original and connected directly to the pc. Yesterday everything worked and didn’t change anything. Change usb port has brought nothing. Windows recognizes the base under devices but does not recognize true drive.

oes anyone have a solution?


does the wheel move left / right in the “Set up USB Game Controllers” screen in Windows? Also, do you hear the normal beeps when the device starts?

My wheel just began doing this with the latest update 2022.5 It is recognised in Windows device manager, all axis and buttons and it makes the normal connect beeps.

It is plugged in as the only device on a USB3.0 hub and worked on that until I changed it to a 3.1 hub then back again. Really strange because it shows up normally in USBDeview but just True Drive does not see it at all. The hub is 100% working as I checked many other devices and all 4 plugin points are good.

Do you run iRFFB with HidGuardian? It might be that it is blocking True Drive from talking to the device.

No I don’t run iracing. I mostly in Automobilista 2 recently. Other thing still happening is where the wheel freezes momentarily then resets and continues working. This usually happens mid corner when there is a sudden spike in the FFB like if hit by another car or run into a wall.

I am having this problem still over a month later but will post separately because I answered and then had no further advice.

Try to get 100% rid of the device from the device manager, then after reboot put it back to either motherboard USB or to the USB hub that worked before, additionally disconnect the new hub you were using if possible. I can’t remember the exact procedure though as I’m on summer holiday and not in front of my computer, but I think usbdeview or something like that may help you.