Simucube 2 PRO bricked

My 3 week old Simucube 2 stopped being recognised by my PC. I read older threads with similar cases so have gone through the process of disconnecting every cable, changing USB ports, changing USB cables, plugging device into multiple PC’s and still no results. The device was working fine up until today. I booted my computer on, went and made a cup of tea and suddenly heard the torque disable sound. When I came upstairs the device was not recognised by my PC, no lights were coming from the power port on the back of the unit but the power brick still showed a light indicating that it is powered.

Please make a support ticket.

If there’s no light on the power connector after checking it’s properly attached, then either the cable of something in the base has been fried.

Maybe contact the seller to check/replace the unit in that case as it’s almost brand new.

already sent one out, thank you.

I’ll try contacting them during the week as they’re closed for the weekend. Thanks for the help.

User error, windows update solved issue :roll_eyes: