Simucube 2 Pro 360 degrees off center

Hello everyone . Ok so ive been noticing after i power on my SC 2 Pro that the wheel ( physically is center ) how i left it last used but in true drive it is always 360 degrees off center every time i power it on . I have to move the wheel back to 0 degrees .

Yes ive use the permanent center option and the restore factory center . But still same thing happens .

Thanks in advance for any help.

1 Like

Soon to be released fw update will fix it. Mika to confirm.


I have the same issue with my Simucube Sport. Usually it turns slowly in the new , 360 degree shifted zeropoint. I had it one time that it went with very high speed and torque in the new zeropoint , it nearly hurt my hand. Fortunately nothing happend. since then I check the alignment angle of the wheel after starting

We are in process of fixing this issue. Most likely it is now fixed but needs testing before we will release. One of the last things to do… :stuck_out_tongue:


I look forward for this update. Thx GD team.
Same bug today.

Most likely will be in 1.0.13 or 1.0.14, will not make into official 1.0.12 release.

1 Like

Sooner is better but I understand that you are overloaded with work.
Thx !

I don’t get why this problem is still not solved with highest priority as it actually can cause injurys when you don’t think about it but the annoying beeps or the even more annoying new automatic torque off comes to us because of “safety reasons”.

There is still barely any torque if you are out of the game and have the e-stop not pressed. The wheel is not turning around for itself.

But if you do a setting in True Drive while you remain ingame it could really hurt you which is a real safety issue.


It is being fixed right now, and the fix is in testing. It has had high priority, we can reassure you of that. We just won’t want to hold back the release of other stuff so 1.0.12 will be compiled later this week and officially released.