Simucube 2 not detected in True Drive


Recently my simucube 2 doesn’t connect in true drive. In windows usb controllers it shows up as expected. In this window i can see the controller moving, as I turn the wheel.

In truedrive however, it says “disconnected”. Also, as I power on the unit, windows detects it, simucube beeps, but then it doesn’t currently do the multiple beeps which it normally does when getting detected by true drive. Any idea if this is a software related issue, or a hardware problem?

I’ve tried powering the unit on/off, restarting, toggled the emergency stop etc. Problem persists.

Also tried swapping USB cables, didn’t fix it. I’ll also mention that I have had the occasional disconnect during races. Not often, but it has occured in the past.

Any ideas what to try next?

Edit: forgot to mention, solid blue led.


Multiple beeps would be when True Drive enables the high torque mode.

Do you perhaps have installed HidGuardian that comes with iRFFB or something? That would block all apps including True Drive from communicating with the device.

Hi, no I have read about those (or at least iRFFB), but haven’t tried them. Based on the fact that the device is recognized in windows, do you suspect a software/driver issue? I could remove simucube from the rig and try connecting it to another pc.

Hi, quick update. It looks like that the reason TrueDrive didn’t recognize the wheel was due to two reasons occurring simultaneously.

I think I updated TrueDrive prior to this occurring, without testing the wheel at that moment. After that, later during the same day TrueDrive didn’t recognize the wheel anymore. I tried uninstalling old versions etc. TrueDrive also prompted me for a firmware update, which I couldn’t perform due to the wheel not being recognized. I then tried swapping USB cables as well, without success.

However, I just realised that the software in fact could perform the firmware update with another cable, and after this the wheel was recognized again.

I then tried the old cable, and the wheel once again wasn’t recognized. So I guess the cable must have been damaged at some point prior to updating TrueDrive.

It was simply a coincidence that I updated the software, and the cabled had been damaged just prior to this. Still strange that windows recognized the wheel, so maybe partially damaged? I’m confused about this, but seems to work now! :slight_smile: