Simucube 2 not connecting to True Drive 2023.2 anymore


Recently I am having issues where Simucube 2 Pro is not able to connect to True Drive. I am using Windows 10. All updates are installed. I don’t think there is a hardware issue, since Simucube 2 Pro has worked on this computer about a week ago, using the same USB cable, the same USB port. There are no errors in Device Manager. SimuCube2 Pro has been identified as a Game Controller and the windows calibration tool recognizes steering wheel movements. Also DIView (to calibrate my pedals) recognizes steering wheel input.

The issue is that True Drive seems to be hanging after start up, saying “Operation Mode: Disconnected”.

The logs:
00:38:40.272: with logging
00:38:40.288: Opened style file
00:38:40.522: Warning: QMetaObject::connectSlotsByName: No matching signal for on_scbuttontimer_timeout()
00:38:40.538: got saved trayicon mode 0
00:38:40.538: QVariant(QString, “notset”)
00:38:40.538: “C:/Program Files/Simucube 2 True Drive/Simucube 2 True Drive Paddock.exe”
00:38:40.538: startup registry key is not correctly set.
00:38:40.538: wheel image: attempting to load: “C:/Users/h0mes/OneDrive/Dokumente/Simucube 2/wheels/wheelimage.png”
00:38:40.538: wheel image: internal file was loaded due to not found.
00:38:40.554: “C:/Program Files/Simucube 2 True Drive/simucubeprofiles.ini”
00:38:40.554: “C:/Program Files/Simucube 2 True Drive/profiles_autobackup.ini”
00:38:40.554: “C:/Program Files/Simucube 2 True Drive/profiles_autobackup.ini”
00:38:40.554: sww dialog hide()
00:38:40.554: loadIncludedFirmwareVersion: included 1.3.55
00:38:40.554: profile settings are not password protected.
00:38:40.554: skipping sending, tracker not initialized
00:38:40.569: Warning: QMetaObject::connectSlotsByName: No matching signal for on_scbuttontimer_timeout()
00:38:40.597: UPDATE CHECK: valid last update check date in registry, update checked <3 days ago
00:38:40.597: UPDATE CHECK: version stored in registry: “1.3.55”
00:38:40.598: got saved trayicon mode 0
00:38:40.770: Paddock load via delay timer
00:38:41.021: “Profile Online webenginepage loaded! 0”
00:38:41.530: EULA previously accepted.
00:38:41.659: Disconnected state
00:38:41.659: unable to open device, pid: 3423
00:38:41.675: Connected to SC2 Pro
00:38:41.675: reconnected


Thats strange. Something is blocking the communications. Hid Hide, HidGuardian, and such softwares are known to do that.

Hi Mika
I have not installed such applications. This morning I upgraded to Windows 11 just to be on the very latest that Microsoft offers in case the problem gets solved and happens again later. Obviously that upgrade did not fix the issue.
Regarding blocking the communication, I will check something there. I have Android Studio installed, which allows you to debug using an emulator. That emulator installation failed until I enabled Hyper-V as an additional feature in Windows. I will investigate in that direction, since otherwise I am a lost. I doubt that is the root cause, but lets see…

Btw. have seen you are working on a new True Drive. With that issue I am having, one improvement from my side would be to ensure the application is not blocked while waiting for USB signals, so it can be closed nicely and restarted again. That doesnt fix my problem, but I would feel more confident that the process is properly killed.

Here is the solution:

The communication between Simucube and TrueDrive is failing because of “Citrix Workbench”. I have it installed with option “App Protection” enabled. After uninstalling Citrix Workbench I have no more issues with TrueDrive. It shows “Operating Mode: Operational” and functions as expected. I was able to reproduce the issue and fix several times.

Mika, I guess you can add one more application known for blocking communications.

Good point, I think we had a support case where Citrix App Protection was hijacking all HID device communications where as it clearly should only get mouse&keyboard.