Simucube 2 and City Car Driving

I cannot get Simucube 2 Ultimate working with City Car Driving.

I config True Drive 900° and bumpstop.
I config City Car Driving to use the Simucube 2 wheel as driving axis and it is recognized, but when I load/start a driving session and the force feedback starts, the wheel turns uncontrollably to left of right.

If I press e-stop during loading the session, start the car and drive, then re-activate the wheel, it seems to work fine. Obviously something during session loading freaks out the driver/wheel base.

Obviously I am not sure if this is due to a problem in SC-driver/FF implementation, or CCD, but I’d very much appreciate if I could get it working…

I spoke with Mika about this briefly. I uploaded a few videos of the problem a little over a month ago. Yes, restarting the SC2 after the game has loaded temporarily fixes the issue, but once you go over a bump or a curb, the issue comes back.

CCD is a nice casual driving game I like to play very often. Unfortunately because of this issue, I no longer play it and have uninstalled the game. It would be nice to have this resolved, however I can see why this game isn’t really a priority.
1 Like

Hi, thank you very much for your reply and message! It’s good to hear that you confirm the issue. I was not sure if I miss something…

Well, there are not too many driving simulators out there. I run all of the obvious ones (iRacing, rFactor, Race Room, AC, ACC, PCars), I just recently I tried F1 2019 but this is a no go for me as it does not support keyboard or mouse!

I’d consider City Car Driving rather a simulator than a game and I’d therefore hope that we will be able to use it in a simulator eventually…

I have just bought this title.

It would be nice to know if it is just something simple, like inverted FFB. Can you guys try with “low” ffb settings from True Drive, it would be quite obvious not-full-force all the time if the FFB was just inverted somehow.

I thought about that first. But it does not make sense that it works fine with the workaround we described having the wheel turned off while start and activating while sitting in the car - then it does work like supposed - until it breaks again like Blvck described in detail incl. videos in certain situations.

I also don’t understand how it helps to feel the same thing with less force?

I tried it in low torque mode as well. Same result. The force feedback is fine once the wheel is restarted in game. When driving it feels like it’s working as it should. If I turn the wheel to full lock and start driving, the wheel would eventually return to center like it should. The problem comes back when you go over a bump or curb. Go over one of those and the wheel turns full lock either left or right.

Does this title have unfortunate limitation on number of controllers? I can’t get it to detect the Simucube 2 steering axis in any of controller modes.

I don’t think there is a limitation, as I run

  1. Simucube Ultimate
  2. Fanatec conversion set
  3. DSD Buttonbox
  4. DSD Button box
  5. Heusinkveld handbrake
  6. Heusinkveld shifter
  7. SRS shifter
  8. Heusinkveld Ultimate pedals

and I can use all of them… Configuration tool is a bit unintuitive though, easy to overlook some settings/drop downs…

You may also visit the support post I posted in the forum there. Devellopers linked a video of how to set wheels up properly. I did that, it’s still not working due to the issues described here. But the axis are correctly recognized in the their config/settings, so the wheel and axis are recognized correctly.

I noticed also various other issues with other “B-titles”. Like bumpstop settings doesn’t seem to work correctly on various titles (wreckfest eg), but I guess that’s related with the implementation as well… But cannot be the issue of the game titles as the DD2 worked fine there as well…

On the good side - so far I didn’t experience any 360° crazyness lately using the new beta driver! : )

ah - I read somewhere it helps to decrease available wheel rotation to 540/720 for configuration purposes. Select custom/default wheel, choose steering axis and turn wheel from center all the way to one side and back. Same for the other side. Was a bit tricky, but like that eventually the wheel axis got recognized correctly.

If necessary I could try to recreate that and make a video…

I did that as well, also removed all my other controllers, still not detecting.

Hm, I just tried and re-configured the wheel axis without issues, but I also struggled in the beginning… Just not sure what was the brakethrough…

I remember that I checked the windows joystick configuration tool and calibrated the wheel axis there too. I think initially there was an issue with the wheel axis there…

Does the wheel axis work fine within the windows joystick config settings?

Yes it does. I will calibrate tomorrow for a second try.

OK; I did get it to recognize the wheel after calibrating also in Windows.

However, I’m not getting the FFB settings options to show at all.

aha, now found it! is hidden as a settings group in advanced options.

OK, managed to repeat the issue with full left force when starting the game, and then pause menu -> simucube off-on -> unpause -> there is a centering spring force. However, after that, I could not repeat the issue of full left/right while on a kerb.

I will need to compile a custom firmware to see what actually happens differently on the device side…

1 Like

I’ve now briefly investigated this. There are both game-based issues and issues due to the game using very rarely used DirectInput features that are by no means physics based.

  1. On start, the game creates effects of type 255 and 0, which are unknown effect types. Simucube does create these, but they are not used in torque calculation logic.
  2. Then game creates effects of type Ramp, Square wave, Sine wave and Triangle wave.
  3. Then game creates an effect envelope (but need to investigate which effect is that for). Simucube firmware does not parse effect envelopes as of right now, as we’ve never before come across a game that uses them. Therefore, this can cause issues.
  4. Then the game proceeds to stop and start all created effects.
  5. Then the FFB loop in the game seems to start to operate. On each loop iteration, it will set new parameters to the RAMP effect, and proceeds to restart the RAMP and Square Wave effect on every loop iteration. This is clearly not required and is something the developers could fix.

Next will need to investigate which effect the envelope is for and to see if parsing it would solve issue.

Ah, scratch that, the type 255 I see is constant torque command.

The game sets its magnitude to -10000 which causes full torque to the right just when game finishes loading.

Additional debugging tells me that the unimplemented effect envelopes are for the square wave and triangle wave effects and they are not even active when game starts.

I’ve posted my findings also to the City Car Driving forums now, but it appears that as a new user it has gone into some sort of moderation queue.

Absolutely great debugging Mika. Hopefully this gains some traction with the devs over there and they look into it as well.