SimuCube 1 stop working with new NGP - Next Generation Physics (Richard Burns Rally, RallySimFuns)

In the game opotions all is fine but on the truck the wheel has problems and not working as you can see on this wideo, other steering wheels do not have this problem:

I think this is somehow related to that game. We had a similar report in Discord lately, that some physics things were not running so nothing worked in-game.

Hmm… but why other wheels working? Looks like only SimuCube 1 and SimuCube 2 is not, more ppl on RSF Discord complain. Maybe it is possible to fix this? I can’t live without RBR :frowning:

Last I heard everything has worked fine with RSF, so its probably to do with something that they have changed in the mod things.

With a Simucube 2 Sport R2 there are no problems. Did you make a scan in the launcher settings?

Yeah mate, settings are fine. One guy with SimuCube 2 Sport got this problem too…

A pity! I saw it on Discord, a lot have trouble since today. Luckily for me, everything is still working with the new update. Did you try the alternative which was offered?

You mean older NGP 769 instead new 772? Can I join online tournaments with older NGP like VRC? NGP 769 works with Practice only if I good understund mika-n. Support is temporary.

Yes, I myself don’t have any problems. All is working well, from shifter to handbrake, Simucube 2, all ok. No lag, nothing.

In their Discord channel “mika-n” posted the version 769 plus an explanation on how to do it

Now both NGP working online but 769 will be off soon in few days so this is not good solution for me. They can’t keep two different NGP online. There is good news, SimuCube is working with FFB Off. Better this than nothing.

I of course understand you. It’s more a temporary solution, until you have identified the source of the problem. An unpleasant situation you are actually stucked in.

Strange that it’s working fine for me.

I also joined RSF Discord just now, its not just Simucube that is affected, also MMOS and Moza etc.

Thank you Mika! It is strange but this is how I fixed this problem, mika-n had good idea and it works:

Yeah, I think they are discussing now why that would help and what is going on. I think the NGP plugins have had some other mysterious issues very recently. I heard the in-game clock was not running at correct speed, for example.

Lets monitor the situation, but looks like its a “bad” release that they should either revert or solve.

Please try disabling RBRHUD Plugins

It was not RBR HUD, Gauger Plug-in, Light, RBR Controls, all disabled. VSync On or VSync Off with frame limiter helped. Mika said, there can be in-game clock problem with high FPS (VSync Off) like few hundreds, and we have desynchronisation game/steering wheel. Would be nice to give this suggestion by Mika to WorkerBee NGP creator on RSF Discord. To set correct in-game clock speed should not be difficult I think.

I have a full gsync monitor. So maybe that’s why I don’t have any problems?

Just turn VSync Off in RSF launcher and in NVidia Panel Settings and you will have big problem with your SimuCube if you have good PC (high FPS). Should not be like this be coz some ppl prefer VSync Off with no frames limiter.

I just use vsync in Nvidia panel, not in RBR launcher. And it’s imo not a FPS limiter, but a variable refresh rate system from the monitor.
I play RBR in 5120x1440 on a full gsync Samsung 49 with 240 Hertz. I never have/had problems (thank God). But gonna check out frame rate next time, and let you know bro.

Something is coming soon… did you see this in other games?