Simucube 1 Intermittent Connection Drop

Hi everyone

I purchased an Augury H 30nm (second hand but in new condition, 40k encoder) around 3 weeks ago.
The first week it was working flawlessly, then all of a sudden the drop-outs started.
No matter what I have plugged in via USB in different configurations it intermittently drops connection every time I have the simucube turned on.
I have a log and dxdiag attached but ultimately this is the problem I get:

Debug: automatic applying of settings to SC not required
Debug: timeout failure1 at “askSimucubeStatusNew()”
Debug: askSimuCubeStatusNew disconnection
Debug: disconnection due to status update read failure.
Debug: automatic applying of settings to SC not required
Debug: Disconnected state
Debug: pid 3418
Debug: reconnected
Debug: got a response
Debug: “C:/Users/teame/Desktop/simucube_fw_1.0.25/VERSION”
Debug: included: v 1 . 0 . 25
Debug: fwupdatePrompt: device reported 1 . 0 . 25
Debug: first connection done
Debug: no need to update
Debug: checked fw update need
Debug: got profiles
Debug: got hardware settings
Debug: got analog data and settings
Debug: automatic applying of settings to SC not required

I have searched over all the forums online and tried many different things to try and rectify the issue -

  • The USB cable is plugged straight into the USB 2.0 in the motherboard
  • I have tried another brand new USB cable which is really didn’t like at all
  • I only have 3 other USBs connected and they are all in USB3.0 (External soundcard, USB 3.0 Hub, Vive)
  • I bought a PCIE USB 3.0 card to take the load off my motherboard, I have my keyboard and mouse in this currently
  • My sim gear (jetseat, pedals, shifter and handbrake) are all plugged into the USB3.0 hub, with external power
  • I have gone through the bios and disabled all unused USB ports
  • I have gone through device manager and disabled all power management on the USB Controllers/HIDs
  • All USB drivers are up to date
  • Simucube/Granite firmware is all up to date.
  • The power to the box is on a completely different circuit to my PC.

I’ve seen that VR can mess with it but it is still doing this even with the VR off. I have the servo grounded to my rig also.
After trying everything, I don’t know what else I can do.
If anyone could help it is greatly appreciated, when it is working it is absolutely incredible which is why this is driving me insane.

SC1_log.txt (49.5 KB)
DxDiag.txt (104.8 KB)