Simucube 1: how to prevent "angle set by game" (R3E)

Simucube always overrides my tediously created setup’s and tells me that it’s got the steering-“angle set by game” (raceroom).
current workaround for me is to then load a read only profile and to switch back to my actual profile afterwards that the wheel rotation is 100% aligned again and the bumpstops where they’re sopposed to be. until simucube decides to go back to using the angle set by game, e.g. when progressing from qualifying to a race. changing the profiles during race is also problemativ, for obvious reasons.

This is very frustrating as you can imagine. so, how can i

  1. prevent the software from using the steering angle set by game (turn this feature off entirely),

  2. make a read only profile with my own custom settings since i cannot change the one available, wich is just plane standard settings that cannot be altered, or

  3. how can i get simucube to detect/interpret the values given by the game CORRECTLY so it correlates 100% with what i see in game? (i spent literally days trying to achieve this!)

current version is 1.0.30/1.0.40 and i did not have these issues when simucube was still in beta

thanks in advance for your help! :slight_smile:

Raceroom indeed uses the API we provide for setting the steering angle by game. They implemented it just under a year ago, so if you played Raceroom when Simucube was in beta, then it did not yet have this functionality.

It cannot be disabled from the device side. I do not believe any other wheelbase has a setting for disabling the same functionality either.

I think there might be a setting hidden in Raceroom config files somewhere for this.

But, why would you want to use “wrong” steering angle? Or does the feature work incorrectly?

yes it is incorrect.

it either moves the bumpstops to a wrong position or the wheel rotation is no longer aligned. as long as the angle is set by game, i was not able to find a setting that just gets it right. i thought this problem might vanish after a few months but i have it like this for quite some time now and don’t know how to fix it.

right now i got my profile set to 900° and the bump stop range between 360-450, depending on the car. this setting works just perfectly as long as simucube does not use the ingame value.

so as stated, one of those three solutions would be fine for me, like using a custom ‘read-only’-profile, or by finding out how to get simucube to read the values correctly. am happy for anything that helps me to get into the right direction. in the meantime i’ll google how to deactivate this on R3E’s side.

Ah yes, it only affects the steering range. The bumpstop range is tuned via offset from steering range, so it will also change.

I suggest you set bumpstop range to 900 degrees too,and then the bumpstop will be correct while in game.

the 900° steering range are only correct if not altered by the ingame value. if angle is set by game it cuts the ingame rotation by half so when im at 90° it shows 45° ingame, while the bumpstops seem to remain where they were. so i can rotate much further than it does ingame. when trying to change this by using the slider, i can get it to feel right, however it then does not do enough rotation at the wheels so i cannot really turn. so this does not work either for me. i tried using 900° setting for rotation as well as the bumpstops.
any idea what i am doing wrong? and thanks for your kind help so far!

EDIT: i tried using both 900° in simucube while fiddling around with fixed values for the graphical steering range and putting this to 900° as well simply does not work. i have to go to about 300° ingame to have it match my 900° set in the software. when at 900° it rotatates too much ingame but stops after 180° of rotation, but i can still turn the wheel further and hear the tires so it’s still steering.
when setting the mentioned 300°’s it’s kind of usable but still about 180° degrees rotation, which is not accurate and the wheel alignement is no longer linear, so i see more movement ingame at the very end of the steering range, in the center it’s not noticable.
i don’t understand how this has gotten so complicated, i just want to set one angle in the software as well in game and that’s it.

Test with 1080 also…

my settings
no issue on my sc1 biss-c

This does not work, not matter what angle i set. 360°, 900°, 1080° the result is always the same. as long as the angle is set by game, the graphical ingame rotation is always double of what i’m actually doing on my wheel. also the ingame rotation ALWAYS stops after 180° even though i can turn my wheel much further and hear that it’s still steering beyond the visible 180°. even when setting a custom angle and not the ones from each setup.

i could not get it right even once for the last few month’s and am starting to get desperate^^

Do you default here?
For example : Porsche cup endurance

Other test possible

  1. rename Mes Documents\My Games\SimBin\RaceRoom Racing Experience in Mes Documents\My Games\SimBin\RaceRoom Racing Experience.old
    2)launch game
1 Like

ok i think this did the trick, cuz i had to reassign the steering axis and now it’s linear again. simple as that it seems :sweat_smile:
however, graphical steering still stops after 180° of rotation no matter what. my actual wheel rotation with bump stops is on point other than that. any idea how i can fix this?

EDIT: i had turned on ‘wheel + arms’ in my ingame setup, this prevents the visible wheel from turning further than 180°! i did not know that, but now everything works well. thanks very much for your help guys!


Don’t use “wheels+arms”