Simucube 1 Granity connection issue

Hello guys,

I have a small mige + Ioni Pro HC + Heindhein Sincos encoder + 480/720W psu

They all work perfectly fine. No problems what so ever in iracing.
My encoder is a 3,7 mil encoder but I have been using it with 64X setting (about 1mil cpr)

I wanted to change it but it seems I can’t connect to Granity. It simply does not see my device.

-Yes I have both USB cables pluged.
-Yes I made connection available from Simucube software before trying to connect to Granity.

Simucube HW version: Revision 1(r004)
Simucube FW version: 0.50.4
IONI drive firmware version: 10710

Running on Windows 10

What should I do?

Thanks.

I have tried following:

"Power down, set switches to dfu mode. Use the DFU tool to flash the Simucube-bootloader.dfu from the 0.50.4d directory.

Switch off, set dfu switches back to normal.

Download 0.11.2 FW, open the GUI from that directory, and if the Simucube is then detected in Firmware Update mode, proceed to flash with 0.11.2 FW first. Verify FW update mode from Hardware and Devices , there should be an icon on the bottom informing of the device status, i.e. DFU mode, or FW update mode, or Simucube Game Controller…

After this, use the GUI from the 0.50.4d release and flash it to the latest."

But what happens is, when I open GUI from 0.11.2 FW it says the firmware is too new for it to handle.
I did this few times. I guess my device does not go into FW update mode.

When I go to Hardware Devices, I don’t see: FW update mode, or Simucube Game Controller. It’s just described as HID Compliant Game Controller. (When I switch to DFU mode, I can see it as DFU device)

HELP!

If you upload just the simucube-bootloader.dfu file, you will not actually erase the firmware from simucube. But why whould you want to do that? You still have 0.50.4 firmware installed there.

For Granity connection, you should simply click “Enable IONI USB Connection” from the Advanced tab. Then you would be able to connect via Granity; note that you need the X4 USB port for this so if you only have one USB cable, you need to switch to the other USB port on Simucube.

Granity connection does not have anything to do with DFU modes…

Looking at the first post, it is most likely that you do not have the correct/required FTDI Virtual COM port drivers for the X4 USB port.

You can also just shut down Simucube, move the DIP switches to put Simucube to DFU mode, and power on. That way the IONI servo drive can be accessed via Granity via the X4 USB port.

Do you have a link to the correct FTDI Virtual com port drivers?

Has it changed over the last 2-3yrs?

No, it hasn’t changed.

https://www.ftdichip.com/Drivers/VCP.htm

I’ve seen the drivers replaced with something else on some systems, and then some windows install had somehow managed to detect a Microsoft Serial Mouse on the COM port, which had to be removed.

Useful tool is to use “View -> show devices by connection” in Device Manager.

Ok , Thanks for the info.

As you have seen there have been quite a few of help requests lately. And with the problem ones it is nice to have another trick up my sleeve. :smile:

On new builds I always install this on someones build. I remember at some point in time we really did not need to install it anymore, but it became habit.

Nice troubleshooting tool tip “Useful tool is to use “View -> show devices by connection” in Device Manager.”

I always go and look if the Simucube Icon shows up in Hardware devices printers. and check to be sure that the wheel is moving correctly there. and that the bump stops work.

If for some reason the drivers get replaced by something else should the correct driver be installed when you run the FTDI chip driver program, or do you have to manually delete the wrong driver first?

@Mika Thank you for answers.

  • I have installed drivers. No changes.
  • I have used dip switches to put Simucube in DFU mode but still not possible to connect from Granity.

What should be the next step?

Here is how things look, when Simucube is in normal state.

Here is how things look when I use switches to put it in DFU mode

In both cases there is no COM connection to IONI through Granity.

I have tried connecting SimuCube to a laptop today. (Both USB connected) I have tried everything above, and everything is exactly the same.

Unfortunately, based on this feedback, we cannot rule out some type of hardware failure related to the X4 USB port or associated FTDI USB chip on the board.

Is this a new Simucube board?

Hi Mika,

I have ordered mine from your first days back in Indiegogo times.
Do you think a .drc file can solve my problem? All I need is to change 64x to 256x.

Thank you.

@Mika

So I got a .drc file from Brion. I used it via SimuCube configuration tool (without Granity) and now on the hardware setup page encoder count seems like 3.7 million.

Does it mean it’s ok? Or Did I just load a mis information to software and nothing changed in hardware? Or if software says all is ok, then all is ok?

I did not run any tests in Iracing yet. But I assume difference between 1 mil and 3.7 mil will be much less then 40K to 1 mil anyway. So in order to release my self from possible placebo, I want to know technicaly is it possible that this .drc file might realy changed my hardware settings, in my situation?

You likely do not feel any difference between 1M and 3.7M CPR.

If the hardware tab now shows 3.7M and the wheel rotation in Configuration Tool matches your physical wheel, you are good to go.

Once I set with the Configuration tool, I had no issues.
And I can say I feel a difference in Iracing. Not million years a drift but It become somehow more civilised more refined. I am realy happy with the result.

Thank you.