Simucube 1 connect to software

Has to be tomorrow, same time as last Saturday, Steve, can’t make it today :wink:

1 Like

Steven, let me go and install TeamViewer on my other PC, if you’re around, sent me the login details :wink:

I want to poke around a few things on your PC too this morning, please install this ->

I will be around for a short while longer, then off to run some laps on iRacing.

sent you PM

I got the HWINFO installed

I’m here
Just use notepad if you need me to do anything

Beano 1.
Simucube 0


Now time for a walk and coffee, whilst Stevo tests his setup out. Will be back in an hour, Steve!


So did you get it working?
Please PM me with details.

1 Like

Don’t tell him Beano!

Now that is just mean!:crazy_face::grin:

Glad you guys got it sorted. That had to be the grouchiest build to connect to a new PC that I have ever seen!!

It was like my doggy, nope I am not going to do it. I don’t care what you say!!:grin:

Hello guys,

I have a small mige + Ioni Pro HC + Heindhein Sincos encoder + 480/720W psu

They all work perfectly fine. No problems what so ever in iracing.
My encoder is a 3,7 mil encoder but I have been using it with 64X setting (about 1mil cpr)

I wanted to change it but it seems I can’t connect to Granity. It simply does not see my device.

-Yes I have both USB cables pluged.
-Yes I made connection available from Simucube software before trying to connect to Granity.

Simucube HW version: Revision 1(r004)
Simucube FW version: 0.50.4
IONI drive firmware version: 10710

Running on Windows 10

What should I do?

I have tried following:

"Power down, set switches to dfu mode. Use the DFU tool to flash the Simucube-bootloader.dfu from the 0.50.4d directory.

Switch off, set dfu switches back to normal.

Download 0.11.2 FW, open the GUI from that directory, and if the Simucube is then detected in Firmware Update mode, proceed to flash with 0.11.2 FW first. Verify FW update mode from Hardware and Devices , there should be an icon on the bottom informing of the device status, i.e. DFU mode, or FW update mode, or Simucube Game Controller…

After this, use the GUI from the 0.50.4d release and flash it to the latest."

But what happens is, when I open GUI from 0.11.2 FW it says the firmware is too new for it to handle.
I did this few times. But when I try to update firmware from 0.50.4d release it does it. It says it find Simucube in Fw update mode.

When I go to Hardware Devices, I don’t see: FW update mode, or Simucube Game Controller. It’s just described as HID Compliant Game Controller. (When I switch to DFU mode, I can see it as DFU device)

When I enable IONI USB CONFIGURATION and open Granity, it does not even show any COM option. Only TCP/IP option.


Try loading 11.1
It worked for me.
I’m not official support.

Make a new post too.

I only used 11.1 to recover yours from the dfu issue it was having, Steven, I would definitely always advise using 11.2 as the first flash…

As a start, I suspect Tolga are missing some drivers on his pc, going by his message. Mika has given him some advice, so he needs to go check those. I think Tolga is getting confused between Ioni and Simucube bits and pieces wrt the softwares…

Tolga, you cannot flash 50.4 FW and then expect to use 11.2 GUI to access the Simucube. You need to use the 50.4 GUI as well, it is married to the FW version.

Also, show us a screenshot of your devices under the control panel, please. If you cannot see the device in the Granity list, you are missing the uart driver for the port…

@phillip.vanrensburg thank you for answers.

I have uploaded pics. to my original post.