Simucube 1. bricked?


A few days ago I moved my computer from a different location. Only 10ish meter.

Only the computer was moved.

I have not raced anything from that date, though I did Connect and power on the Simucube just to check if everything was okay, it went through its initialization as normal (movement and sound), simucube and ioni Led constant Green.

so my first belief it was all ok.

Now, When i wanted to race, starting up Simucube it still goes through its initialization as normal (movement and sound, simucube and ioni Led constant Green.)

But the wheel is not recognised by the computer, and the Simucube software will not find my wheel. I have tried MMos and Granity, they do not find it. I have run the DFUDemo application which does not find it.

I have used the DIP-switch, no difference.

Simucube v 0.50.4c

Using usb x4 is is detected as Ft230x and comport # but wil not connect in granity.

Ionic pro hc have come up2 times in 100tries in granity. But when i try to Connect i get an error message. And the iono board start flashing LSSS. The other times granity hangs in «opening Bus».

Usb x3 does not show as connected at all.

Reinnstalled all usb drivers. Enabled/disabled all hubs/ports. Enabled/diasbled usb3 in bios.

Ereased all old/hidden connections using usbdveiw,

Only simucube, mouse, keyboard is connected as usb. Tried 4different cables. With/without feritt emi protection. And all the usb ports on motherboard. Front and back.

I have tried with 3different computers. 2windows 10. computers.


Is my simucube board broken? Is it bricked? Any quick fix, or do I need to buy new board.

Any advise?

Is there a Simucube visible in the device manager at all via the X3 USB port?

No. No simucube, or anything related to the simucube x3 port in the device manager. Only the «serial connector» Ft230x at x4.

Have you tried with another cable? Is there any physical damage on the connector?

No damage on the connector, tried with 4 different cables. With and without ferrit emi protection.

I dont know if this can give you more detailed info Mika. But the x4 outputs 2,03v. The x3 nothing.
Tested both in dfu mode and not.

There is typically no supply voltage being supplied from USB device to host, so you are essentially measuring just some floating voltage.

Does the LED on Simucube (not on IONI servo drive) light up at all?

Yes. Led nr 3 is Green. Constant.

OK, that means that the 3V regulator is up and running. How about when you start the device and would expect the wheel to be normally operational. The firmware should turn some additional LED on when you turn over the bumpstop. Can you test that?

Yes, led nr 6 lights up Green.

That shows that the microcontroller is alive.

As this happened in conjunction with the move of some stuff, I suspect either the USB ESD protection diodes have taken a hit / burned, or that the microcontroller’s USB has just died somehow. It is rare, but can happen. System might be OK if those diodes were replaced.

So, as a dd ninja, you belive that the «fault» is at the simucard end, and not the computer end. And replacing the simucard or fixing the diodes wil fix the issue?

Yes, I believe its in the simucube end this time. You can try to verify this if you have a laptop to try out with.

Do you know if the Simucube is under warranty or not?

I dont belive the simucard is under warranty. So i need to fix this myself one way or another. The dd wheel is a kit from simracingbay. Is has been working perfect, and without any hickups until now.
Thank you so much for your time and knowlegde.

Email our support for details on the diode. Your local electronics repair shop will most likely be able to replace the diodes. Might be worth to try to repair.

1 Like

I can also ping @Esa here on Monday.

1 Like

@ Mika is the Simucube board sensitive enough to ESD that someone could kill the board via ESD just by touching the metal end of the USB cable?
I would assume the outer shell of the USB port and cable is ground?

The ESD protection diodes are supposed to handle that but sometimes even they can fail.

If it is a brand new computer System build you may need to download the FTDI Driver from FTDI… sometimes windows does not install this automatically. It doesn’t really sound like the board is actually bad from what I read…

The problem is IF you have the SimuCUBE firmware on it Granity will not be recognized unless it is in Granity axcess mode AND MMOS will not recognize it at all without reinstalling the MMOS firmware.

FTDI drivers are absolutely not required for the X3 (USB game controller port) to work.