SC2 with CubeControls Wireless - some rim buttons not registering


Has anyone encountered issues whereby some buttons on wireless rims fail to register with the Simucube 2 Pro?

I have a brand new Simucube 2 Pro, and I’m on my 2nd brand new CubeControls GT Pro OMP Wireless rim - having returned the first one assuming it was a fault with the rim. The buttons which fail to register are the exact same pattern as my first rim - so it seems too much of a coincidence. I’ve de-registering and re-registering the rim, tried plugging the SC into different USB ports (USB 2.0 and 3.0), tried different USB cables, tried unplugging as many other USB devices as possible, tried turning off all devices nearby that emit a radio signal (routers and phones). I’m running True Drive version 2021.4_4, updated SC with the latest firmware, and True Drive says the signal strength to the rim is 100 and battery is 4.00.

This image shows the buttons that do register marked green, and don’t register marked red. Like I said - exactly the same pattern as my 1st rim.

Any ideas?

Where are they not registering? In-game, in True Drive, or in DiView, or …?

Hi Mika,

The buttons I’ve marked red in the image are not registering in True Drive or Windows USB Game Controller Control Panel, or in ACC, AC (when trying to map a button to an action) - obviously those marked green do successfully map to an action.

I’ve also tested the buttons using DiView with these results (each registering an UP and DOWN event)…

Button 8
Button 9
Button 10
Button 11
Button 12
Button 13
Button 14
Button 15
Button 16
Button 17
Button 20
Button 21

Is there any pattern to this?

Have a cube control gt pro zero wireless and all buttons you shown are functionnal in TD for me with my SC2 pro rev 2. Any problems since first day, it’s a high level pleasant combo !

That’s sort-of reassuring to hear this isn’t a very common problem - thanks @R1jerome.

It’s probably worth mentioning that both of the back-lights on the momentary toggle switches light-up when activated, yet only 1 registers at the PC end. Which implies it’s not a physical fault with that switch, and seems increasingly likely that it’s an issue with wireless communications or a wireless module, and since the rim has been replaced once already with the exact same fault pattern it suggests to me it’s the module in the simucube?

@Mika - your thoughts please?

1 Like

It is very unlikely that the issue is at the Simucube side - the module just passes the raw pin data to Simucube firmware, which then interprets that based on a configuration table that is downloaded from the wheel.

Maybe Cube Controls has misprogrammed a batch of their wheels?

Okay - thanks for your input @Mika. I’ve been exchanging emails with Cube Controls support - let’s see what they come back with.

Hello again. Just wanted to post a final update - I now have a fully functioning CubeControls wireless wheel rim working with my Simucube Pro, after 1 MONTH of messing about with configs, hardware, and returning several rims. The issue, as @Mika suspected, was caused by a batch of CubeControl wheels leaving the factory mis-programmed. Kudos to CubeControls for their diligent support.

I think it’s worth mentioning that although mistakes were made, there’s a lot to be said for using standard wireless/bluetooth over the proprietary API. While there might be some “dislike” of microsoft’s implementation, I suspect that the “mis-programmed” wireless module might have been resolvable by myself with a firmware update if that were an option.