SC2 Ultimate Problem - No Power Up/Status?

I used my SC2 Ultimate for a good 4 hours yesterday, and it worked perfectly. It was turned off at the mains overnight. This morning I went to turn it on and it will not power up. There is no light at all on the status light.

The yellow light on the power supply is on so I know that there is power coming from there. The E-Stop is not showing any status light either, and pressing the power button or stop on there does nothing. I have unplugged everything from the back and then plugged the power and e-stop back in in the recommended order, but that didn’t seem to help.

Does anyone have any ideas / seen this happen before? I find it hard to believe it’s a connection issue inside the unit as it worked well all the way to the end of the last race I did. Thanks

Connect USB cable to another port on the PC. If the USB is not seen for some reason, the device will not power up.


USB power is needed for the device to power up. Let us know if simple troubleshooting things do not resolve the issue for you.

Yep, I meant it was possible that his USB port was tripped/down for some reason, perhaps due to faulty cable. Two easy things to check, hopefully that sorts it for him.

Hi Phillip, Mika,

Thank you for your replies. You were right, somehow it was the USB connection. I spent some time shuffling things around and eventually it just powered up, and has been great since. My fault, such a minor issue.

I also spent a lot of time trying to troubleshoot it without the USB cable plugged in, which obviously didn’t work :sweat_smile:. Will know for next time.

Thanks again.

Cheers Mate, glad you’re up and running again :wink: