SC2 Ultimate disconnected at start up


Just got my SC2 U and plugged it in today according to instructions.
Downloaded True Drive 1.0.10.
Switching on power supply, pressing black button on off-swith. (No light from button).
Operating mode: Disconnected

Tried different USB ports with different cables that worked for other devices.

What now?

Many thanks for your help!

e-stop pressed maybe?

I have tried to have it pressed and unpressed. Nothing happened.

The light in the back of the motor have never lit up either and the motor have never made a sound.

Simucube 2 devices do not start if there is no power supplied from the USB. There have been less than handful of issues with USB cables. Can you try with another USB cable, and also another computer (a laptop will do) as well?

Yes, I tried with a different USB cable that worked with my pedals but no luck.

I will try with a laptop tomorrow night since I don’t have one at the moment and post results here.

What is the serial number of the unit? It is on a sticker on the back of the device.

Serial number: 00000904

I have now plugged it to a laptop instead but the results are the same. There’s no sign of life. The light in the back of the motor as well as the light on the torque off button does not light up and it’s still disconnected in true drive.

I also didn’t receive an antenna to mount in the back of the motor. I also didn’t receive mounting screws for the torque off button.

Is this the way it’s supposed to be or did my package miss parts?

Hi @Viktor .Does the light on the PSU come on …Are you using the original cable from the wall power socket to the PSU

Hi, the only light that illuminate is the one from the power supply.

I only use the cables that I received but I have tried with different ones to make sure there’s is no problem with the cables.