SC2 Sport strange behaviour

Hi guys, I am having a strange behaviour with my sc2 sport, since a couple of days I am feeling the wheel much stiffer than usual, all bumps are much harsher to the point I had to lower the ingame ffb level, and the driving is overall much less precise. This happens in any sim by the way. Off course I am always running high torque and didn’t change anything at all in TD, I tried to change usb port and usb cable with no luck. I checked all wheel to base connections including the 4 bolts that holds the shaft and also my HRS Xero Play qr but all seems fine.
The only things that happened in the last 2 days are a couple of pc crashes while in iracing and the failure of a pci express 5 ports usb card which I had to remove from the pc.
Could those events be related to the problem?
Any suggestion? Thanks,

Was the SC2 plugged into the PCI expansion card at the time it failed? I’m not sure that would damage the servo but I’m wondering if that could have somehow damaged the PC motherboard.

Is there any way you could test the SC2 on another PC to compare the behaviour?

Hi Paul, I solved the issue by uninstalling and reinstalling the sc2 from win10 control panel, have literally no idea why but it worked :slight_smile:


Perhaps the windows calibration values were messing things up.However, iRacing should not be affected by that.

1 Like

What did you mean by reinstalling SC2 in Windows? Was it through Device Manager?

Did the issue happen after a Windows update? Maybe an update screwed up the drivers.

Would like to know that too

hey guys sorry for the late reply.
no, it didn’t happen after a win update, and I simply did “remove device” from control panel, turned off sc2, and just turned it on again so that it reinstalled it automatically, with the win10 notification “new device…”.