SC2 Pro won't initialize after FW upgrade to 2021.4_3 (Fault location ID: 250101)


yesterday I thought I could update my SC2 Pro from 2020.10 to the latest version. Started the FW upgrade. Everything went fine. The wheelbase restarted, but nothing. No beeps. Waited a bit longer, still nothing.

So I started True Drive and it showed me β€œE-Stop is released. Motor Faults (cycle E-stop to clear): Initialization Fault Fault Location ID: 250101”

So I cycled the E-Stop multiple times: nothing. Switched off, plugged off the PSUs and waited 5 minutes, plugged them back in, started again: nothing.

Downgraded to 2020.10, worked on the first try. Also 2021.1 is working. Tried upgrading from 2021.1 to 2021.4_3, same issue.

Whats causing this and why only with the new Firmware? The ID is listed in the fault location wiki entry, but to be honest I don’t know what to do here.


Please write me to PM and paste the device identification data that gets copied to clipboard when you click the button in the last tab in True Drive. You can do this in 2020.10 if that works.

And, I do not know that fault number, we need to check separately what that might be.

Hi Mika,

thanks for your quick reply. Just sent you a PM with the data.

Send you another PM, Mika.

But for everyone else:

I opened the backplate as to this and my cabeling was exactly like this. I properly routed the cabeling and upgraded to the newer firmware. Wheelbase started without any issues.