SC2 Pro wheel rotation not being 1:1 in rF2

So currently have a problem with rF2 where in the assignment screen of rF2 & SC2 firmware the wheel is rotating 1:1 (e.g 360’ IRL = 360’ on both pages) however as soon as I enter the car I suddenly have a limited range of being only able to turn at most 180’. I’ve tried the following and none of it has worked,

  • Turned all aids off
  • Tried using vehicle set ticked & unticked.
  • Tried a different degrees of rotation amount in the assignment & SC2 firmware.
  • Loaded the SC2 built in profile.
  • re-assigned/re-calibrated the wheel.
  • Tried plugging the wheel into a different USB port.
  • Checked the controller.json file and all is correct.

If someone knows a fix for this issue it would be greatly appreciated if you could provide it.

you need to match dor into json file and into true drive, otherwise it won’t work

The DOR in the json file & in true drive is the same as each other. Even when changing both to be either more or less DOR than what I had originally, it makes no difference and I still end up with the wheel maxing itself out at 180’ of lock