SC2 Pro out of the box error 485001


New unit out of the box, no torque always error 485001
Unit performed firmware update on first connect…
Same thing with or without high torque mode
How to fix?

Toggle e-stop to clear the fault.

We tried to implement a definitive fix for this fault in 2020.7 firmware, but it appears that we need to adjust it further for next firmware version.

Toggling the e-stop only clears the error for a few seconds. I cannot see any torque on the setup, it is always blank or 0 Nm

I had the exact same problem [ID: 485001] yesterday when I first booted up my new SC2 Pro running firmware 2020.7.

After some reading here on the GD forums I had a few things to try that were suggested from the regulars. What worked for me:

Start with everything switched off and True Drive closed.
Toggle e-stop out.
Power on power supplies & motor, wait for the beeps.
Open True Drive, don’t touch the wheel and wait for the device to become operational.
Load or create a new profile.

You should now be able to adjust settings without the communication fault, as well as have the correct overall strength value.

1 Like


Tomorrow morning it seems to work OK, after booting up with these directions. Thanks!

1 Like