SC2 Pro Not Working

Our friend SC2 pro device does not work
The light on the PSU is on. I haven’t tried it on my own device. Because my device is dual psu
I tried the e-stop button on my own device, it works
What could be the problem?


have you tried another usb cable ?

Not PC connection. Device does not turn on at all

i don’t understand if you tried another usb cable or not with your answer.

Maybe I didn’t explain. Device does not turn on

Seems like PSU fault problem is pretty normal with SC2P

Does this mean that there is no USB connection to the wheelbase? As far as I know there needs to be a USB connection for the wheel base to power on.

1 Like

There needs to be an active usb connection to the pc before the device will power on. If it doesn’t power on, chances are you have a bad usb cable.

Replace it and plug to a different port, or test on your laptop, for example.

1 Like

thank you for all the replies . the problem is the usb cable . I don’t know if the usb should be plugged in . Thanks everything

1 Like

Cheers Mate, glad you’re sorted :wink: Enjoy!

1 Like