SC2 Pro - Need to be in Car to get FFB while starting TD

Hey there,
i used very old TD Software for some time now. After updating to latest i now got the problem, that i need to sit in the car (iracing) while starting True Drive Software, otherwise i won’t get any FFB. Everything normal in True Drive, everything enabled and detected. Anyone know what i’m doing wrong or got a work arround?


This sounds very strange. Does the last tab in True Drive show the list of created FFB effects if you first start True Drive and then iRacing? True Drive does not affect starting/stopping FFB effects in any way.

Hi Mika, thanks for fast response.
It says Constantforce in bold and Damping in normal.
I’ve tried starting TD -> iRacing -> jump in car -> no ffb
I’ve tried starting iRacing -> TD -> jump in car -> no ffb
I’ve tried starting iRacing -> jump in car -> ffb

Not sure if this is the same thing, but when I start up SC2 base, I initially have no ffb.
In TD once I toggle between profiles everything works normal.

also tried toggling profiles, deactivating/activating high torque mode, still the same.
also noticed it never works on first start, no matter what, even if i already sit in the car.
second start of TD and in the car is the only solution that works for me right now ;(

There must be some type of common thing that makes this happen. It does not happen at our office rigs, testing rigs, nor at my home. Strange.

And we haven’t seen any reports about this in our support either, just the two of you here on the forum.

Finally found out whats going on. I had a profile with very low ffb sets as default.
Even when TrueDrive displayed everywhere that my “normal” set was loaded, there was still my as default selected profile loaded. Its all gone after i put my “normal” set to default.
No idea why it was working when jumping in the car and starting TrueDrive. So probably just a display bug in TrueDrive because it shows the wrong profile as active and loaded.

Will confirm I reset my default profile to the correct one and all was normal directly after start-up.
Was fairly sure I already had the correct profile as default - something must have happened to make it switch at some point, maybe making a new profile and accidentally setting it as default.