SC2 Pro - intermittent freezing of steering input to iRacing

I have an SC2 Pro, the original 2 PSU version. In the last couple of weeks i’ve started getting a very intermittent problem where the steering input to iRacing just freezes mid race, last about a second and then it updates to the current position and is fine again. There’s no clipping/hands off beeps when this happens. I’ve checked both PSUs are plugged in okay.
Any ideas what might be causing this?

I think i managed to capture this in DIView (as a way to rule out iRacing from the problem). There’s a steady stream of minor changes, then at the bolded line, no changes for just over a second, and then see’s a massive change (this freeze happened as i was trying to turn into a corner)

I’ve tried a different USB cable into a different port, still the same. It takes about 20-30 minutes of driving before it happens. I’m running 2010.10 truedrive/firmware which is fairly old at this point, but has been trouble free for the last 12+ months. I’ll install newer software tomorrow, although i don’t expect it to make a difference.

Hello. I got a same problem at SC2 Pro with 1 Power supply.

You solve this problem with update the software?

I just wonder about that

Thank you.

I tried different USB cable, different USB hub, upgrading firmware to 2021.07. None of that helped.

I eventually realized that i had disconnected an arduino that simhub was using around the time the problems started. I’d hadn’t changed the simhub config, so it was polling all the COM ports looking for it all the time. I tested without simhub and didn’t have any problems, and after reconnecting the arduino haven’t had any problems since (about 10 sessions so far). So it would seem that it was this, but it doesn’t make any sense to me. The SC2 isn’t exposed as a COM port, so i don’t know how the simhub poller would have any impact at all on the SC2.

Good luck solving your issue.

I know this is old, but did you ever figure it out? I get same thing every so often?

Yes, see my post above about simhub’s com port poller

Thanks for the reply, i use sim hub as well , but no Arduino,just straight transducers. Wondering if the other guy who replied figured it out. I had same thing with my csl DD.

Do you know if there is a way to turn off the com port poller? I might have to test with sim hub off to see if it is causing my issue, but I can’t even go back to driving without transducers lol

You can configure which ports the poller will check. I’m not in front of my rig right now, but if you can’t find the setting I can post a picture later

Thanks , would appreciate it. I’ll have a when I get home.

I don’t know if it even shows these options if you haven’t configured it for an arduino. But this where you change the com port poller, aka “scan settings”