SC2 beep behaviour not following check boxes

OK, I’m new and might be making a stupid mistake, hopefully someone can help. I did a search, but could not find it already asked.

I need to race as silent as possible, because my partner sleeps in next room and I race when she sleeps! I have two sets of beeps I want to remove

  1. clipping - I drive skippy in iracing, I understand the clipping bleep is a good aid to correctly tune the IR settings, however to keep the room quiet I need to turn it off. I unchecked the box in TD for clipping notificatio, yet when in IR, I can be either driving or stationary (and waggling wheel left right) I get clipping beeps from SC2 - although the IR black box never changes from green (it does go half way across, or 0.5 numerically) but always green even though the SC2 reports clipping. Ideally, I’d like to be able to disable the SC2 beeping, but really also want to understand why SC2 reports clipping but the IR black box does not

  2. high torque mode (e-stop release) the 3 beeps with this - I do not think can be turned off, is that correct? I need to be able to use the e-stop on an evening when not in the sim (when in the lobby) to be able to stop the SC2 for beeping every now and again warning high torque is still enabled even though no inputs being received. I also want to use the e-stop every time not racing - to avoid DANGER (as spelled out in every thing I read) :slight_smile:



The beeps you hear are probably the hands-off detection. Set it to low to prevent it.

The startup beeps can not be turned off. Hopefully it will be implemented in a future TD release.
However you can put the device in automatic high torque mode and then you will not have the warning beeps so you wont have to use the estop to prevent them either :slight_smile:

1 Like

Thanks for the info. Are clipping beeps different to hands off?
I actually tried hands off yesterday for a different reason and got no beeps. My hands are definitely on when I get what I thought are clipping beeps and I am always applying turning moment when i hear them, they are usually associated with a slide after apex … I’ll try teeeking the hands off

The hands off detection on high is a bit too edgy IMO, you can get beeps from it even when your hands are on the wheel. At least, that was my experience in the early days. I have turned it to low and since haven’t had any beeps for iy anymore.
I also turned off the beeps for clipping and I don’t hear them anymore, even though I sometimes have clipping in the sim (red bar for FFB in iracing), so that setting in TD works fine :wink:

Ok, I’ve read the user manual … this is it, def hands off and not clipping. I can recreate when stationary with rapid left right and also when driving it is always when I am correcting a spin. However both times hands are firmly grasping the wheel :slight_smile: but be the way the algorithm works
I’ll tweak the hands off setting tonight

1 Like

What are your iRacing FFB settings?

I never have SC2 Pro clipping. I typically run 25/50-75 (linear) depending on car, 100% in TrueDrive.

I wonder if you’re running off a single power supply? Both connected firmly?

I meant to upload the pics on the original post.
I have the max force high, because I have a shoulder injury so want low torque (but obv the high fidelity compared to my g27)
Even after reading bjsohn’s oost I still do not really understand the lower “wheel force” slider.

Having PSU problems does not lead to the issues mentioned here. That would cause a complete drop of forces when crashing for example.

Any safety related beep tones cannot be disabled.

Also, it is not recommended to keep the “high torque mode without beeps and without standby mode” on for, e.g., many days, with the e-stop not pressed, as the current driving transistor are then being kept powered and it could cause wear on them.


Could also be a problem leaving the motor on with e stop pressed for multiple hours? Lately I turn it on in the morning till the evening, but with e stop pressed when not in use.

When e-stop is pressed, the FETs are unpowered.


OK, so what I was experiencing was definitely hands off - I changed the setting to low - and now zero beeps when driving.
Regarding the beep when not in the car but high torque enabled - I’ll have to try and work out the frequency and make sure I get back in the car before it goes off!

Good to hear you solved problem 1.

But like I said before, if you auto-enable high torque at TD startup, you will not have the warning beeps for idling at all.
You will still get the beeps when going from estop mode to regular operating mode, but apart from possible safety concerns there’s no reason to use the estop when you’re not racing for short pauses.

Hi, I thought that was what I read earlier - but it had not sunk in (auto-enable high torque), thank you so much - great community spirit :slight_smile:
On a different note, I’m LOVING it, I now find I can drift (aka correct a slide/spin) - immersion+10


1 Like