SC2 always baseline PROFILE load at startup, why?


Is there any way to make the base remember my default settings without having to open up TrueDrive? Cmon guys, i come from Argon and i dont even remember to have to go into mmo’s for a long time. In software it says, saving to simucube… but it doesnt save s***… I’m not really that happy to be dependent on software for such a simple thing. Anyway, i could be wrong and there is a way to do this… Any help apreciated.

Hi Carlos_Diegues,

Have you set your setup to Default in td software?


yep. but after restarting sc and if truedrive is closed it apply default…

You must click the save -button after setting the default profile.

i also set as default after apply. and still it does not keep profile without opening true drive… it goes into baseline with crazy amount of damppning and whatever that makes the wheel turn to the inside alone…

did it just now… save settings to sc, set as default, save to sc… set default… save to sc and same…

as a side note, do you guys have plans to get less reconstruction filter? coming from argon base, honestly i feel it has too much filtering but if i turn it off it makes really bad noises and the feel is not that sharp.

The device is in the safe torque mode until you enable the high torque mode. This is a safety feature. You can automate the high torque mode but True Drive must be running.

Honestly, i dont like that feature when i have already stated in the profile i created that i want 100% of my wheel strength, either way, it still does not keep the profile i created after reboot without truedrive. I will try if it saves in low power mode. If i wanted low power i would pick a csw2.5 as the feeling is about the same.

I’m trying to understand your problem. Is this what you want:

  • Start up your PC
  • Start up SC2
  • don’t start up True Drive
  • use your wheel with the TD settings you last saved to the SC2

Am I correct?
If so, I don’t think it’s possible, because you will always need to at least start up TD and have it “recognize” the SC2 unit.
If I understand correctly, after that you can close TD again. But as soon as you restart your PC, you will have to repeat the process again.

Why don’t you just use the automated TD windows startup and auto-high torque modes? Have TD start to windows sys tray, so you won’t even notice it’s there.

it is correct. but why cant the sc keep that? saving for latter revision or what? this doesnt make sense in 2020. in default settings the base does not need TD to work. so why should it need to TD to set my default profile that i previously stored to SC…

Maybe instead of the Save button saying “Save to simucube”, say like “Save Profile” or “Save in TD”. Because it does not save to SIMUCUBE.

It does save to Simucube.

For liability reasons we can not make tge device to permanently have potentially unsafe high torque settings. This is why the High Torque mode must be separately enabled.

So maybe put a new acessory called, torque key, like competitors…

It was a decision very early in product development to not add a torque key or similar feature.

However, thanks for the feedback.

Ok. Maybe increase the max safe torque a little more? Say… 9nm or 10nm

1 Like

I would much rather have to open True Drive than plug in a physical thing (that I could also possibly lose)

I don’t understand the issue here — just add True Drive to your startup items?

There’s also no way 9 or 10nm is “safe” - it also doesn’t really solve the issue of having all the other settings off.

1 Like

The issue is, i create a profile, i enable high torque and accept what is there about injuries and stuff, i set as default and the base doesnt let me keep it. Just that. Like when mouse started to have software based profiles, then onboard memory so you didnt have to keep instaling software.

And again, if it kept filters the same as what i set before and only reduced power mode, but no… full on default settings

You can set high torque to automatic - it’s in the setting when you enable it.

Also, if i put it as a task, cant i forget it is in High power mode and just be as prone to injury as letting me set it in the profile??? Its simple…