SC1 issue - slight vibrations, uneven feeling, hard to explain

hello and welcome. what is the hardware ( motor, encoder , psu etc) you are using and what firmware , plus what software (mmos , simucube) and in which sim.

Hello! It’s simucube software 1.0.30 with the newest firmware, a small mige motor with Biss-c encoder, Meanwell sdr-480 psu. Using shield cable with no EMI issues.

The “rumble” issue happens when the simucube is turned on, no matter if plugged into the PC or not or running a sim.

please post your simucube settings and maybe a video showing the problem. But your settings atleast for starters.

Thank you!! Here is my setting in Granity and Simucube tool. Video can not show the feel, there is no movement or any visible vibration. When I touch the wheel or the shaft, I can feel it, the first post above explains this “noise” feel very accurate. I tried to set lower MR and ML values, but not affect this too much.

granity|387x499

If you set torque bandwith to unlimited does it change the feeling that you are experiencing?

To my experience, torque bandwidth not affect this at all. :frowning:

is this something that started after changing some setting or was it from the beginning ? i am trying to understand if it is something in the software or maybe something from the hardware.

For starters i would set mpp to 0 since your psu is capable to drive the small mige without this setting. apply the setting and then hit measure resistance & inductance , let it do it’s thing and then apply and save and see if helped.

Thank you, I’m going to try this to see if it helps .

The issue is from the all beginning,I’m more convinced it’s from the hardware, have tried everything in the driver but it seems nothing related to it.

I’v also tried two small mige motors so I’m sure it’s not from motor side.

Tell me when you test it. I ll be waiting for your response.

Also although it is a longshot , please increase FOV to 51 . I don’t know if i remember correctly but if it is close maybe it is overheating your regenerative resistor. Could be tottaly wrong but it will surely not hurt your system.

I’ve tried to set mpp to 0 then measure resistance & inductance, found no difference.

I found no matter what the setting is, this feeling is very constant after power up.

Thank you I have changed the FOV to 51.

for the same reason increase fuv to 30. And maybe it feels not linear because of low mcc , try setting it 0.50 lower from mmc , so 12.36 . I doubt though that any of these can impact the wheel the way you are describing it. Maybe Mika could help you because i don’t think it is something related to settings but i could be wrong.

Lower MMC is not impacting that feeling, I found lower the MR and ML to extremely low values like 1.0 will reduce it but can not eliminate completely.

I checked the box and wire connection, it seems everything is OK and grounded.
Thank you so much for the help!

Not lowering MMC , i do not recommend that. It is said to be better to have a small gap between mcc and mmc to have linear feel, that’s why i said to increase mcc to small gap of 0.50 lower than mmc.

MR and ML should be set to what the measure tool suggests. You could set them to what the shervo maker suggests but i think it is better to just do the measure. Setting them to those low values ain’t what you want to do.

OK! I’ll reset the MMC and MCC according to your suggestion. Thank you!

For MR and ML settings, I just found it’s the only setting that affects that issue, but it certainly not the solution.

Figure 19: 130ST-M10010 perfect settings: MR 2.6; ML 11.5

i doubt though that doing those settings will fix what you want since they are higher even from what you were using and it is a fairly old guide.

Yes, raising MR and ML value makes it even worse. I think it’s probably the hardware or electric things.

Hi, this is quite normal on certain servos, I had the same on my Lenze and couple AKM servos. Not much one can do wrt this, but feeling will disappear once you apply some filtering in the tuner window.

Perhaps you may try also to reduce TBW limit to around 450-680Hz, see if that helps. But anyway, it is impossible for Tero to tune the internal filters to accommodate all servos to that degree, it will be many years job.

So as per my original comment further up, this is normal, won’t damage servo and is related to resonance, or maybe slight amount of cross-talk in electronics. You can also try different Ioni FW files, as I am sure Tero tuned around this issue few years ago, if memory serves….

Not possible - the latest Simucube 1 firmware requires the latest IONI firmware as well, due to a change in the Simplemotion API.

Torque bandwidth limit has no function here if the feeling is also felt with no torque signal present.

Lowering the MR and ML values effectively reduces the gain parameters of the drive in torque mode, so it may be able to help.

Yeah, I meant older TD and FW both, if it is a hassle to the OP :wink:

maybe if he enabled CIS – Set point Smoothing ? dunno if it has ill effects though.