SC1 : Ascher Racing F28-SC not detected anymore

I have the Wireless module for a while now, maybe a year. Had no issues before.
Both my Ascher Racing B16M-SC and F28-SC were working correctly.
A few weeks ago, maybe 4, I focused on Supercars V8, so used only my BM16-SC with no issues.
Even after upgrading to latest Simucube 1 firmware/software ( SimRacingBay ).
Simucube Revision 2 r005
Firmware 1.0.22
Tool 1.0.22
IONI firmware 10716

As said, no issue with my BM16-SC recognized in a second, but yesterday wanted to do a GT race, and used my F28-SC, and it didn’t get detected my the tool. The led in front of the F28-SC is blinking green, 1 quick flash every second. but it is never recognized.
I try several things:

  • click clear list and restart scan, but it’s already empty
  • tried with the BM16-SC connected or not
  • tried hold both F28-SC paddle when turning it off ( I remember it’s to reset it ? )

I sent an email to Martin Ascher, but didnt get any reply yet. So posting here also.
The battery is certainly fine, I got it same time than the BM16-SC and it was turned off when I didnt use it ( I know otherwise when I used my BM16-SC I would have seen 2 wheel ).

What Can I do?

maybe start with updating to the latest firmware 1.0.25 .

Oh, shit, I though 1.0.22 was last, updating right now

Still not working
BM16-SC still working

It most likely is, as the BM16M-SC is still working.

Will see what Martin say, battery shouldn’t be any issue , they are supposed to last 3 years.
Antenna, looks like brand new, no wiggle, doesn’t seems broken.

Ofc you are correct but the cost is minimal so i would replace the battery to be sure

Yes, I have no idea what battery it is, I don’t think it’s the kind you find easily in a supermarket.
I ll check tomorrow. exhausted from the iRacing GPL race.

Local camera shops can be good places to find one.

However, my hunch is a loose antenna connector.

Martin sent me 2 antennas and 2 batteries ( I guess to cover also my BM16-SC in case of troubles ).

And well, I guess I was unlucky on that, both antenna and battery were the problem.
I changed the antenna, and found the old one was broken, the coil was broken from the base. And after that it was still not working, So I changed the battery and it worked right away with 100% strength.

EDIT : I don’t know how to change the tittle of the thread to [FIXED] …

1 Like