SC Pro 2 version 1 loosing connection

Wheel base disconnecting after 3 to 5 minutes of use.I’ve been using 2021.1 since February and never had any problems. I updated to 2021.4.4 and it disconnects. It gives me the unrecognized usb device in device manager I see an option in True drive that you can log the data for trouble shooting I guess but I don’t know which settings to use for the logger.

That log is from the device side and thus you can’t download it if the device is disconnected.

Do you have USB selective suspend turned off in Windows power options? Having it ON can cause issues.

And, please update to latest version, we only offer support for 2021.9 release.

Mika the USB selective suspend was already disabled and I also upgraded to 2021.9 and my wheelbase continues to disconnect and reconnect I recorded footage of it while driving in iracing it would disconnect and then you hear the beeps and it reconnects constantly. Then it stays disconnected and gives me the unknown USB device message in device manager. here’s the link to the video

Have you tried

  1. Checking that all USB connections are tight
  2. Replacing USB cable
  3. Using different USB port on PC

Also check if there are any pending Windows updates requiring restart, Windows usually starts acting funky when there are any.


I had already tried all the usb ports on my hub and on the rear of the PC after reading your reply I went down this morning before work and plugged it in to one of the usb ports on the front of my PC and I was able to drive around around Road America in iRacing for about 10 minutes without any problems. Hopefully that was the issue I’ll give it a true workout today after work.

do you have motion rig?

Yes I do have motion I have the SFX100 . I’ve had the motion for 3 years and I’ve had the SC2 Pro for 2 years and I haven’t had any problems with disconnects before.

I would test with motion turned off. That would be a very easy way to rule out any EMF from motion.

It is very possible that something in the SFX hardware is putting out more EMF than it used to.
Understood though that if has worked for two years you wouldn’t think it is the issue. :slight_smile:

1 Like

Usually front and back usb ports are using separate controllers.
I remember from WMR days there was an issue with AsMedia USB controller and solution was to uninstall it from Device Manager and let Windows pick up Microsoft driver for it.


Be careful with hubs. Ive had a couple that worked fine for a while then lose the connection. I think motion kills them. I have an sfx also. Also had a bad usb cable cause this recently. My advice is plug the wheel in directly to the pc. Also dont let the usb just dangle from the back of the base. Find some way to support it so its not constantly vibrating.


I just wanted to Thank You Guys for your suggestions with my issue. Plugging it into one of the front USB ports on my PC seemed to solve my problem the weird thing is that my wheelbase had been plugged in the same port for 2 years without any issues. I tested it out today with and without motion for 2 hours and everything is fine. Thanks

1 Like

You are very welcome.

Windows probably changed the order of your USB devices.

And we have always had the best luck plugging direct into the motherboard.

Many of us guys who have been involved with OSW since the beginning run a high quality USB add on card that plugs into a PCI slot.
We have run into big time EMF and USB disconnects over the years. :frowning:

I have the same problem … I never had before.
I think it’s due to the new firmware …
I have not solved the problem even if I changed USB ports and computers …
Really frustrated … having lost a lot of iRating before realizing it was a problem with the SIMUCUBE 2 PRO.

Downgrade to an older version of the firmware and see if that helps. I’ve been using 2021.7 with no issues

Thanks I will try the version you say … I have already done 2021.8 + True Drive Paddock … but it is the same thing.

No USB interface changes between those versions, so very unlikely that they would behave differently.

And then a solution which would be … surely and linked to a firmware update … before I had no problem …
Leaving aside energy usb problems etc … which are quite trivial … if everything went before and now it doesn’t …
Surely it is a firmware problem linked to some conflict with other devices in use … such as pedalboard or VR Oculus or Index … that I use at the same time …
What is the solution you propose?
I opened the ticket … I wrote to Tomo where I bought the SIMUCUBE 2 PRO …
If the solution is to update the hardware to the new version … otherwise what do I do I have a brick that breaks at the next update?


Thanks for the advice,
but this doesn’t work … to give no one hope.

Thank you for your interest “designamk1”