Resistive to one direction of steering &/or spin out of control

I seem to have a couple alternating problems. I have been using a SC2 pro for about a month with no mentionable issues.

At one point after a spin in iRacing my wheel started to spin and I got the fault #442001 for overcurrent/torque. Each time I would reset my wheel, it would slowly start to spin out of control, whichever way I would let it ramp up speed.

After a software and computer restart the device seemed stable again, but I could notice resistance towards one direction of steering. When trying to turn the wheel quickly to the right, I would get some dampening/friction type resistance. It limits how quick I can turn the wheel and makes a sawing type sound. When I would turn quickly to the left, I would get a couple bumps in the feedback but didn’t resist too much.
This is all being done outside of any sim, just on the desktop with True Drive, although the effect is still noticeable while in sims/games.

Took a break, came back and while tinkering the opposite happened - I had more resistance turning left than turning right. The problem was there whether high torque mode was enabled or not.

After a cycle of power and restarting the program, I was met with the wheel seeming unstable and wanting to spin out of control again. When I turn the device on and leave it in low-torque mode it wants to ramp up speed and spin one way or the other. If I let it, the wheel will complete a few rotations (about twice as many turns as it should take to reach the bump stops) and then hits a click and spins freely, but does not want to spin back to the original zero-position past the “click” point. This will happen to the left or the right side, whichever I let it go.
If I turn on high-torque mode, the wheel will somewhat freely spin within its normal range, but once it hits the typical bump stop location the wheel begins to continue spinning past the bump stop with great force until it hits this a similar “click” point and then the high-torque shuts off. I am assuming this “click” region is some kind of built-in safety feature.

Starting the wheelbase and then opening TD seems to put be back to the “resistance towards one side” mode…

I have tried multiple TD profiles, previous versions of TD, tweaked multiple settings in TD but can’t seem to notice any difference (noting I also ran for a month with no issue), tried tightening the 4 bolts on the shaft coupler.
I have seen a few topics similar to this but seem slightly different. Maybe there is some connection. Any ideas?

Try to follow these instructions.

1 Like

Thank you
After the new profile and reboot everything seemed to be the same.
The ctrl+E function seemed to solve the issue!

Interesting how I was getting different kinds of feedback depending which way I turned the wheel

  • bumpy one direction, hard resistance in the other when turning quickly…
    Nonetheless that fixed the problem. You are appreciated
1 Like

Easy come, easy go.
After running the wheel for a bit (about 10 mins) I’ll start to feel a bit more resistance towards one side again. Usually starts faint then gets worse. As I exit (iRacing) and try cycling power, and the resistance just gets worse…
Will update if I find a further solution

Contact our support.

I have a similar issue, I had the same overcurrent/overvoltage protection message last week on my SC2 Pro. But since then my FFB disconnects in random times or the wheel pulls to one side fully until it hits the bump stop. Not sure if this is relevant, but could be related, since my issue began after the exact same “error message”.