Removing SC2 Motor Side QR

Hi everyone,

Just received my SC2 Pro to replace my SC1. I wanted to use my existing HRS Xero-Play QR and after mounting the motor to my rig, tried to remove the SQR motor side unit but am unable to get the bolts loose. A 4mm allen wrench is too big, but the 3mm seems to fit the bolt correctly, but it doesn’t actually turn the bolts, just strips the head. I found a pdf indicating it should be 4mm - but that is just too big, I can attach a picture to show this. Does anyone have any tips?


I’ve heard back from Tomo (who I bought the system from) and he confirmed that the bolt is 3mm. However, I’m not really sure what I can do without risking stripping the head.

They should have some initial resistance due to having some thread locker applied during the assembly process.

Use a good Allen key (not ball ended) and they will release but you might be better to wait for an official reply that gives you the go ahead in case of any issues that may arise.

Thanks - I was able to get them out using a new set of allen keys (thank you home depot for being open late!). I’m now having new issues with the drive getting stuck “initializing” and also had the wheel do a complete restart after a heavy kerb strike, but I’m going to try reflashing and see if that helps.

Just ordered the new motorside extension from SRB. I have same problem here, the wheelside QR is extremely high torque tightened in relation to the size of the bolts. (a few years of usage could also be the cause of this. Besides that, my SC2 was in the first ever released badge, dunno if that matters). These allen bolts seem to be made of chewing gum and have a sort of ‘Chinese QC’ like sizing of in between 3 and 4 mm. Have tried multiple allen keys/ and bits, proper quality tooling.

This coming from a guy that has built his own bikes in his shed, I’m ashamed to say I have lost from a dead object… Damn GD why did you have to cut corners on these 0,02 bolts… Don’t like the idea of drilling these

I did the same for the Simcore one and no problems with first batch SC2 Sport… Strange