Project Cars 2 & 3 does not detect SC2 Pro / unable to assign control

Whatever i try, i cant assign turning left or right for PC2 or PC3.

I select PC2 profile. Start the game , select custum wheel , and go to assign controls. And when it asks me to turn the wheel nothing happens. Or i get something like “multiple inputs detected, aborting” I’ve tried most options from center to 90 degrees and back , from side to side , and not touching bumpstops etc etc. No way. Any clues ?

If you need to assign lets say left you have to turn left and then without stopping return the wheel to towards the center and it should register.

Thats the problem, Ive tried and tried all combinations , but nothing happens. Just gives the error “multiple inputs detected”

I Just turn the wheel Up to the bumpstop without pressure and return it to the center in one motion and it detects.

Assign with estop pressed

1 Like

Thanks, but still nothing. I can turn the wheel forever. Still ends up with same message after awhile “Mulitiple inputs detected. No action was assigned”

Unplug any other peripherals such as pedals.

1 Like

Tried unplugging all game devices. Handbrake, motion platform , pedals. Still same. Reinstalling PC2 as we speak.

Assign pedals first, then go to wheel axes.

Hi! Happy you made it here. Foa, don’t touch anything but the wheel and make sure pedals and buttons don’t send a signal. Use a preset wheel which has already assigned steering. If you manage to assign left just inverse it for right (or vice versa). Is almost always a project car problem and not related to hardware. Just to make sure you should make sure hardware is working correct by using a different sim

In td select your rotation try 900 go to game PRESS your estop rotate to the left go to 430 re center wheel it should register if ok do same to right

same prob with AMS2 every one i have given help to doing it this way always prob solved and ams2 same engine so should work project cars
ps post back let me know if it worked out

1 Like


I managed to solve the problem. It seemed to be that my Ocolus Rift 2 was connected during assigning controls , and it did not like that.

I did some cable management and disconnected the rift permanently since is it not much used. I also reinstalled PC2 - but after disconnecting my rift, PC3 also worked, so I dont think the PC2 re-installation was the solution.

I was able to assign control without having to press the E-stop , and also passing the bumpstop / 450 degrees, but i had to go from 0 to 450 and back to 0 to make it register.