Problem with firmware upgrade Simucube 2 Pro V2

I got my new version of the Simucube 2 (V2) in yesterday and downloaded TD 2021.5. This is my 2nd (first one got zapped by lightning). The first thing the software wanted to do was a firmware upgrade.
It started the upgrade and then the window went away never opening back up. Now when i open the software and turn on the wheel, or turn on the wheel first and then TD, I get “waiting on drive”. It also show that the E-Stop has been pushed. i have tried the old E-Stop and the new one. I need to figure out how to re-flash the drive. No links work in TD while this message appears, so I cannot run any logs. I also tried a previous version with the same outcome. How can I get the drive to take a new firmware load?

The firmware is updated, there is no possibility that you would have gotten to this point with bad flash or anything like that.

However, we are investigating some issues with the latest firmwares. Can you downgrade to 2020.10 to see if that version does work for you?

1 Like


It did take the firmware upgrade. It finished the firmware flash. The light on back around the power connector is solid blue.

I still have the same thing. Below is a pic. Game Controllers reports Simucube 2 Pro is OK.

Can you try with different USB port or different PC as well? This is to rule out any interference issue from USB.

I tried a different port, a different USB cable, and then tried both on a different computer with no change.

OK, lets continue on the support ticket.

I have tried both the old one and the new one.
No difference. DO I need to test continuity on the buttons? If so, please provide a pinout.
I don’t think it is the E-Stop since my old one was working and the new one is giving the same functionality.

Lets continue on the support ticket so that our support staff has only one location where to look from. Thanks.