Problem with firmware installation

I tried to flash my new simucube board with dfu file with dfuseDemo but the software stopped after 1 second saying: device disconnected (something like that) and now I can’t see STM Device in DFU Mode anymore, so I can’t install the firmware. Every led is green. Is there a way to recover the DFU mode?

Have you tried flipping the dip switches on the board to force it into dfu mode?

thanks, yes, tried now and I can see the DFU mode again. But now I have a problem, when I go to flash the firmware the dfusedemo software blink continuously… is it a known bug?

Just noticed now that in the control panel (under printer etc) the STM32 blink continuously. like I’m attaching and detaching it… really strange…

Tried switching usb port, tried removing encoder and motor connection, no changes… Any advice is welcome :frowning:

What wires /connectors having you connected to the Simucube at this point? It might be useful to start with minimal, i. e., disconnect motor and encoder and all from x11&x12 connectors.

update: connecting the card to another pc is stable and they managed to include the firmware. Once installed it became stable. Not so explain the reason … but in the end everything went ok !!! I will keep you registered in case new problems arise. For now everything is ok … and thank you for the advice !!!