[Problem] Waiting for drive to get ready


#1

Hello,

I updated to the latest simucube version (after longly using 0.9.7). After this update there was a problem with E-STOP pressed. I downgraded IONI firmware to 1.7.1 and tried to downgrade simuCUBE software back to 0.9.7, but both simucube software (new and 0.9.7) does not open simultaneously. Also after trying to update IONI, i have a new problem, Granity cannot connect to IONI. I tried using older and the newest versions of Granity.
Photos below.


sim2


#2

WARNING This version is not successful in directly updating 0.10.x or earlier versions at all. Please update to 0.11.2 first, and remember to save settings at least once, for the update to 0.50.3 to work properly.

The version that comes with 0.50.3 is ioni 10710 , that one is not in the ioni firmware releases to download. Can you reflash 0.50.3 ?


#3

We found the issue that makes this happen. However, as said in the download page, upgrade from 0.10.x and earlier just won’t work at all.

What you can do, is to install any older version or 0.50.3 as follows:

  1. install Simucube_bootloader_and_reset_all_settings.dfu file using file from 0.50.3. DfuSeDemo must be used.
  2. Install Simucube firmware
  3. reconfigure motor using the wizard.

#4

suggestion to put bigger font and maybe in colour red for the warning before more people bump with the same issue.


#5

I have backported a fix from later code commits (actually fixed to SC2 on Monday this week), and then investigate also why updating from 0.10.x fails. It is a 30min job to actually setup build environment for 0.10.x so maybe I will need some other way to do it…


#6

Hello, Mika,

thank you for quick reply.

How do I use DfuSeDemo? I managed to find the software and upload the file, but as I understand I should select something from the list which is blank for me.


#7

Please use the “upgrade and verify action” functionality. The Upload is exactly the opposite to the thing you want to do.

You will have to power off the device and move the dip switches to the other position to get the Simucube to dfu mode.


#8

Are there somewhere expanded explanation about moving the dip swiches? Maybe with photos or video?


#9

Dip switches are shown on picture on this page:
https://granitedevices.com/wiki/Installing_MMos_firmware_into_SimuCUBE

Note, that a later revision of the Simucube board has the dip switches moved next to the edge of the board.


#10

I managed to reflash, now I tried to install 0.10.1 firmware. After trying to configure hardware automatically I encountered this problem.


#11

You just need the drc for your motor


#12

It’s small mige 10000ppr, however when trying to upload drc it says Unable to upload drc file.


#13

Why don’t you try updating to 11.2 and then to 50.3 and try the drc then? You restored the switches right?


#14

We updated to 11.2 without problems, thank you for your time and help. Mika aswell! :slight_smile:


#15

And thanks for reporting issue here.

I’m just now installing 0.10.4 back on my Simucube so we can get “working” 0.50.3 upgrade that does not brick the device like this.