Poor wireless connection | SC2 Ultimate

Hey guys, I am having an issue with my SC2 Ultimate, I am using the Cube Controls GT Pro wireless wheel.

I am getting frequent disconnections and the connection percentage usually sits around 20 but often dipping to around 8.

My SC2 Ultimate does not appear to have an external antenna. Can these be retro fitted?

At the moment the Cube Controls wheel is useless as I cant even use it in USB mode as the wheel does not support this function.

Can anyone help please.

@DoZZa: Your antenna sits behind that oval cavity in the lower part of the back plate.
You can try the following even if you think I am mad.

Get some insulated electrical wire (no matter which kind), cut it to a length of 24 cm. Fix one end of that wire with some sticky tape on the top of the wheel base, let the other end dangle down to that antenna cavity lower down the back plate. Fix the end with sticky tape there. Try.
If that does not work, wind 12 cm of the wire into a coil with a diameter of about 3 cm, stick that coil to the antenna cavity, fix the free end on top of the wheel base. Try.

Make sure no uninsulated part of the wire touches the metal of the wheel base.

1 Like

Hey @Joern, that sounds like it could work! I’ll give it a try and report back :smiley:

This resolved the issue! Thank you :smiley:

I will try some different lengths of cable, but right now I am seeing connection between 30 to 70 and no dropouts!

A picture of this solution would be great.

1 Like

Just to update this, I have been trying a few things to improve the signal quality, and I have finally settled on the following.

I have found that a 24cm length of 4mm² (AWG 12) speaker cable seems to work best. I tried a longer and shorter version of the cable, and also different types of cable including coax, but settled on speaker cable at a length of 24cm as @Joern initially advised .

The cable is attached to the base using heavy duty double sided tape along the top, the back and also the opening on the back.

Also removing some insulation from the end of the cable near the opening on the back of the base has made for an improvement in signal quality.

It’s important that no bare metal part of the cable touches the wheel base housing.

Bending the cable upwards on the steering wheel end of the cable has also improved signal quality.

I am seeing signal strength between 35 to 80 depending on steering wheel location with it set up this way.

Hope this helps someone, and thanks @Joern for bringing this ‘hack’ to my attention!


Check out this video, the problem could be on the wheel side with BT antenna cable routing.
It seems to have signal on a low side though, 70% when everything working right, I am seeing 100% on SRB Pro.

Yeah, I saw Will’s video, I tried re-routing the internal antenna cable in a few different ways, made negligible difference.

24cm cable… Any reason why it can’t be longer?
May be possible to use longer cable and enroute it around the servo shaft to amplify wireless signal in all 360º of wheel rotation

That could work, I’ll give it a try later and report back.

I imagine we’re dealing with 2.4 ghz where antenna length would be 28.8 to 32 mm. 28.8mm is the widely used standard. Try that exact amount of exposed wire. At a glance it looks like you’re close. I think technically the exposed amount of wire is the antenna length.

You might try a second exposed bit on the other end of the same length. Is this a tuning fork?

1 Like

Hello guys,
I’m new here and i have problem with my wirelless conection, SC2 ultimate and my Cube GT Pro wireless.
I turn on the GT the SC2 anouncing the the GT, i make the conection but it only stay conected 2 ou 3 seconds. Battery: 3.96v ; Signal strength: 8 to 40%
Can you give me some help?