OSW Wheel - No FFB

I’ve been using Asseto Corsa to test the wheel, it connects, it rotates perfectly in game and the game takes the input correctly however theirs no FFB response, No feeling of road or bumps. The wheel responds to test stimulus in granity perfectly fine. I’ve combed the settings of Granity and MMos and can’t find whats wrong.

Any ideas or help with this (hopefully) final problem forever appreciated!

Motor: Mige130ST-AM100110
Encoder: ZKD-86-1000BM
Board: IoniCube 1x w/ Ioni Pro
Controller: STM32F407 Disco
Software: Granity + MMos

Best to post your MMoS device settings screenshot here….

Also, under Granity settings, ‘Drive Function’, please select IoniCube 1x as opposed to Simucube….there should be such an option….

Already been changed:

Is there any resistance 0n the wheel if you set MMoS Desktop spring to maybe 50% or so?

Tried Desktop and User Spring, both have no affect on the resistance.

I am trying to remember if latest Discovery boards worked correctly with MMoS. I remember there was some versions that didn’t.

After original Discovery boards were discontinued, I used Core407V boards, different pin-outs, but they worked very well. It might be something like that, if you are 100% sure you have PWM/DIR correctly connected between disco and Ioni cube….

If you set IONICUBE mode then you need to wire a separate Enable signal.

If you use test setpoint in Granity, do you get torque to the motor?


Yes, true. I am just assuming he’s wiring according to some of the schematics I made for these OSW’s ages ago. If he follows those standards, he will be ok.

1 Like