OSW MIGE Maximum Motor Current Value


#1

Dear all

how can i change the maximum motor Current in my motor (small MIGE)


#2

If you have just updated to 0.9.2 (and hopefully also 0.9.3 which I just released),

Powering off and powering on will recover the correct Maximum Motor Current setting.


#3

If that does not work, please re-do the Motor Configuration Wizard. You will not need to point it to any DRC file.


#4

If, however, you had the Maximum Motor Current originally at 6.632 A (which is unlikely, but possible), you can do the following:

  1. Press Enable IONI USB Configuration Mode -button on the advanced -tab
  2. Use Granity to connect to drive, change MMC value, and save the settings to drive non-volatile memory. Also press Apply and Restart if asked.
  3. Disconnect from drive in Granity and Re-enable communications in the Configuration Tool
  4. Re-do the Motor Configuration Wizard.

#5

thanks Mika
I am getting the same value. Is there any way that this value has been entered from the granity SW?


#6

please see my third answer just above.


#7

I have 12A set for my large MIGE by default. Also after re-running the Motor Configuration Wizard it stays that way. Shouldn’t that be the value for the small MIGE?

Do I need to purchase a SimpleMotion V2 USB Adapter in order to connect Granity and change just that value? I do not seem to be able to get a connection otherwise.

Thanks.


#8

You must enable the IONI USB Configuration mode from the Advanced tab before you can connect via Granity using the X4 USB port.

The adapter is not required and in fact is not compatible with Simucube.


#9

@Scud: You can safely set MCC to perhaps 23A-24Aand MMC to 25A, if you have Ioni Pro HC.

Cheers,
Beano


#10

I think I am doing something entirely wrong. No “X4 USB port” available…


#11

The X4 USB port is the one on the back of your Simucube, where you obviously have the 2nd cable connected.

That SimpleMotion UART interface in the dropdown menu (highlighted) is the correct one to select.


#12

Thanks for your help. I did try all of the options before (always w/ Simucube in “Ioni Granity Configuration Mode”). Both Mini USB cables are connected via a USB hub. Is this the issue? I do not have two mini USB cables long enough to test. Which of the two would be the one to try with a simple extension cord (I have only one of these here).


#13

You might have too old drivers for the FTDI chip.


#14

Driver seems to be from Aug 2017. Is this old?

However, I noticed something else that might be odd: COM3 seems to be used twice. Is this a problem (highlighted in red)?


#15

Yep, good call, Mika.

Also, Scud, See here: https://granitedevices.com/wiki/SimuCUBE_connector_pinouts_old

Connect X4 directly to pc, bypass the hub as a test. X4 is the one furthest away from the rj45 ports.


#16

Hmpf, now it magically connects. But via the “SimpleMotion serial port (COM3)” device. Not the one you were suggesting above.

Suddenly it also works via the USB hub. Maybe the cable was just a bit loose.

Thanks anyway!

2019-01-25%2009_18_47-Window


#17

Hi @phillip.vanrensburg
Is that _old page linked somewhere on our wiki still? I thought all references were removed.


#18

it is best not to use a hub though. and you don’t need both usb cables connected if you don’t want to change settings in granity.


#19

Yes Mika, that was direct link I just found on Wiki!


#20

according to the wiki tools, no pages link to that page. The original page without the _old was deleted without a redirect. Can you pinpoint it, i.e. is the wiki tool broken?

Please use https://granitedevices.com/wiki/SimuCUBE_pinouts_and_wiring