OSW DD Wheel (Argon based) not working properly (EMI Issues?)

Dear GD community,

I hope I might find help here with a current issue I deal with when using my OSW DD Wheel (Argon based). I started my DIY build back in the old days 2015 when OSW movement was picking up speed in the community.

I still run a small MIGE motor in combination with the Argon Drive setup from the original/first DIY version. On the Software Side MMOS is still in use on my setup.

All this years I had zero issues but within the last days after a longer break from simracing my wheel is not working properly anymore.

How can the issues best described?

  • When I turn on the wheel it phases correctly and MMOS is showing the green connection indicator
  • But at this stage Win 11 is already shown a small clock on the recognizes MMOS Force Feedback device in settings tab
  • When I turn the wheel the movement is not consistently shown in the Controller Game Settings. Sometimes it stops or is lagging
  • When I select one of my settings profiles in MMOS sometimes the connection indicator directly goes to red and USB connection is lost
  • But sometimes it stays green for some time but then within a racing game such as AMS2 I can drive for some laps but in between the wheel inputs stops working
  • When the Motor Stop is active (No FFB) I do not have any of this issues

So overall I wonder if I have suddenly have to deal with EMI issues which were never a problem all this years. I tried to use some grounding cables and had the assumption that it helped for an amount of time but then it stopped working again.

I hope you can guide in a direction what else to check to get closer to the cause of the issue. At the moment I am a bit lost.


have you tried with another usb cable ?

Not yet. I first wanted to post the issue here before making any changes. The setup is the same since years without any changes. Except that my PC got upgraded and is running on Win11. But even then I had no issues.

I will try a different USB Cable to check if there is any difference and report back here.

So ich changed the cable and at least there was no complete connection loss as of now, making MMOS disappearing.

I was not able to test it with a SIM but in Windows it seems that the wheel movements are with better tracking now, there were only a few times were I had short stops or lags. If that was the issue I am more than happy. Thanks Loukas for now!

1 Like

Hey all,

I have to re-open this unfortunately. So I switched the USB Cable and the connection issues in Windows under USB Devices where gone but there is still something wrong within the sims.

When I do a race there is almost always one occasion where the wheel gets a short disconnect and start to feel completly “light” so without FFB. For that short amount of time there is no steering input anymore. Then I move the wheel with a bigger range of motion and it is getting connected again. This is happening with a hard “punch” in the wheel.

I kind of have the feeling this happens during a sequence in game where high FFB forces are applies, e.g after a contact with another car.

Is there anything I can share here to get closer to the issue. Maybe the Granity tabs. I have the assumption I am not dealing with an USB issue anymore and it is hardware related?

Thanks in advance,

This sounds a lot like usb / EMI / ground loop issue.

Allright I bought one of these grounding plugs know which I can connect to my rig. Is there any special mounting point on the rig to get it grounded properly or does the position not matter much?

Quick update: Installing the ground plug worked and I got no connection issues anymore. What was a bit worrying:

During connecting the motor mount while the ground plug was already plugged-in I got an electric spark on the clamp. Is this normal and part of the reason for my connection issues or do I had a bigger electric security risk all the time?


it depends on all the other hardware you have on the rig… difficult to know without having full picture of what is there and how they are connected.

Hey Mika, mh nothing special really:

  • Small Mige Motor
  • Custom Build Wheel from Fi-Tech (USB Connected)
  • USB Hub (with dedicated power)
  • Heusinkveld Pedals

Okay I do not know what to do now. After the Ground Plug did it’s job fine for couple of days, the issue reappeared today even worse with more than just one disconnect within my racing sessions. After all those bug free years I have no clue what is going here now with my setup.

Here is a image from a short video clip with the electric sparks visible on the Quick Release

Check this Beano’s guide.

1 Like