Operating Mode Disconnected

Hello All,

I just received my Simucube Sport 2. Downloaded the lasted software and updated the firmware. E-stop isn’t pressed, lights on power brick and the back of the simucube is on. Still operateing mode says disconnected. Any suggestions?

Try new good quality USB cable and different port, after switching device off/on first…if that doesn’t help.

I’ve tried a different USB cable. Changed the USB power management. Simucube shows up in the devices under the hardware and sound tab in the control panel. Still no go.

Are you using the latest true-drive app that came with the fw? You can’t use the old version app…just to make sure you’re using the correct version?

If so, hopefully Mika will guide you further.

Yes. Using the app that came with the firmware which is 2020.7. Thanks for the reply. Hopefully Mika can help.

This unit has been fixed remotely. We are investigating the cause.


Mine also have true drive operating mode disconnect and active profile unknown issue, open ticket almost a week, still waiting for reply…

I just now saw your ticket and replied to it. Have you contacted the reseller already before contacting our support?