No power to SC2 Pro

I recently lost all control of my SC2 Pro. I have checked everything I can think of to fix problem. Both Power supply are putting out correct voltage (48.5 V) I have Uninstaller and reinstalled Firmware. Which is currently (2020.7). I have double check and triple checked all cords. No issues there. I have tried different USB ports. Nothing!! When I open True drive. Everything is grayed out. Can’t do anything in True Drive. Any help would be appreciated. Thax Ray

Have you changed the USB cable for another (new) one?

happened the same to me some time ago, I solved exactly like that by changing usb cable.

Yes, because the device won’t start up proper without working USB, it is by design.

2 Likes

Does it mean that we have to use only the USB cable delivered with the SC2 Pro?
or can we use a different cable? If yes, how should we proceed?

You can use any (good quality and preferably one with RF chokes) USB cable. Do not buy cheap crap cable, spent a bit more for piece of mind.

This is assuming you do not have one, or yours is faulty. The one coming with the SC2 DD wheel should be of sufficient quality :wink:

OK! Thanks for the info!

Cheers Tony, let us know if you get sorted :wink: