No power - 2 day old Simucube Pro 2

Brand new Simucube Pro 2. Everything was working fine for 2 days. Today I experienced a few intermittent disconnects followed by the wheel reconnecting right away. Now the wheel won’t power on or connect at all. I’ve been searching the internet and can’t find a way to fix this. Very confused.

  • Tried a new USB cable
  • Tried other USB ports and computers
  • Tried other power outlets
  • Tried older versions of True Drive
  • Operating mode stuck at “Disconnected”
  • PSU brick has a green light but no signs of life at the wheel base
  • Power button is on
  • E-Stop is not engaged

Anyone know what to do?

Contact our support.


Thank you. I contacted Simucube support this week and was planning to pack up the Simucube this morning when it randomly powered on on its own. The FFB was working but it’s continuing to reboot itself intermittently. I’m going to update Simucube support but posting this update here in case anyone has dealt with this and knows how to resolve. I’d prefer to not have to ship this thing back if I don’t have to.

I would try with another USB cable.

Thank you. The problem has been solved. It ended up being a bad motherboard battery on my new PC which can cause USB ports to not respond correctly. Although it wasn’t related to the Simucube, hopefully this helps someone in the future in the off chance they experience the same issue.

1 Like

Sometimes the solution is so far away, you never ever think about it. Happy it sorted out for you!
Is a long weekend, wouldn’t be nice without being able to race a little bit

1 Like

Getting a powered USB hub also helped as my built in USB ports on my PC seemed to have been overloaded with all the connections. So much to learn as a newcomer!

Unfortunately, the problem continues. :persevere:

The Simucube will disconnect after about 10-15 mins of use. Switching the cable or port will sometimes solve the problem but other times it can take a while for it to recover and come back on. Like it needs a cool down. The USB cable itself doesn’t seem to be the issue. I don’t know if this is just coincidence but this intermittent disconnect problem did start shortly after Windows forced a system update last weekend.

Disable USB selective suspended and see if that helps

Thanks for this suggestion.

Not entirely sure why this happened but the problem went away shortly after my last post and has been working flawlessly ever since. The two things that made a noticeable difference along the way were replacing a bad motherboard battery on my new PC and running all USB connections through a powered USB hub (which runs into a blue USB 3.0 port).

Thanks for the support on here.

1 Like