No force feedback in GTR2

I know it’s an old game but it’s still a good one. I decided to boot it up for the first time since I got my OSW, and I also installed this:

The game looks great, my wheel and pedals work but I don’t have any FFB at all. I copied the PLR file from this thread and the SimuCUBE settings: Simbin Titles and Simucube/DD
Maybe I shouldn’t have done that before trying it out first, I don’t know.

It’s been a while since I played GTR2…but from memory…I do remember having to open the FFB settings page in game, leave it, then enter track.

GTR2 was indeed reported to be working a year ago. I wonder what has changed.

Well, I started another thread where FFB no longer works in Raceroom which is by the same company as gtr2

@DSaw78 Have you tried rF2 to see if it works there as well? I think there might be something going on with steam and simucube.

Okay, opening the menu then turning FFB Effects off and then back on fixes it. Not a big deal but I wonder what causes that.

rF2 worked when I last played it a week ago but I’ll fire it up shortly and make sure.

Went to play this the other day and now it won’t recognize Simucube. All my other control settings are still mapped (Simucube was as well) but the steering inputs won’t work. Any ideas?

How many controllers you have attached and recognized in Windows? GTR2 has a limit as to how many it will recognize, and Windows often reorders controllers for no apparent reason…

Nothing has changed hardware wise since it worked last time. I have installed an update to the “10th Anniversary patch” the other day which overwrote some files so maybe that screwed it up. It still should recognize the wheel though so maybe a W10 update messed it up.

I bet Windows has reordered your controllers. Check out this tool It works really well for 32-bit games (like GTR2, Automobilista) to trick the game into seeing all controllers in a consistent order, even when Windows moves them around (which it does nearly every reboot, with no apparent pattern).