No endstops and iracing configure problem


#1

Hi Guys,

I am having an issue on a customers simucube AKM53k build.

Everything worked fine when I first built it on the bench.

Now at the customers 2 problems.
No end stops
In iRacing configure control screen the ffb box is greyed out.
When you try to exit calibrate it says need 2 sided axis.

The wheel phases correctly on startup.

I have confirmed that the wheel/ encoder are functioning in the windows hardware devices where you get the grid and crosshsirs.
No faults in Granity.

Please help. :slight_smile:

Thanks,
Joe


#2

Joe, does he have sim-commander running?

But he can delete joy-calib file in iRacing and start again. Sounds like he did not properly turn the wheel left 90deg when prompted, might have gone cw vs ccw, or something such…

100% sure this is either an iRacing config or PEBKAC error on user end :wink:


#3

Hi Beano,

No Simcommander.
He previously had fanatec. Weird thing is he should still have endstops without being in iracing correct?
I normally can feel the endstops at windows desktop.

Thanks,
Joe


#4

Joe, let him uninstall the Fanatec app and driver, this has caused me similar issues with my SS2 when I got it first. I was reviewing a Fanatec wheel just before and left the app/drivers installed, but the wheel removed.

Caused me similar mischief until I did a proper uninstall of the Fanatec stuff…


#5

Thanks Beano,

We will try that tomorrow.


#6

Cheers Joe, let us know how it goes!


#7

Missing FFB and endstops in a new install is a bug in 0.11 firmware. Set endstop settings, especially the ramp range, at least once to nondefault value, and save that to Simucube.

This would not cause the FFB checkbox being greyed out in IRacing, though. Must be some other issue.


#8

Thanks guys I will let you know what happens.


#9

Actually going the wrong way on the iRacing Calibration will invert the wheel if I remember correctly from accidentally doing it once… i.e. left becomes right and right becomes left.


#10

Hi Guys

I got the customer squared away.

I tried all of the things that we discussed and things are working.

We had to unplug his Ricmotec pedals as there was some signal coming from them and he was not sure how to calibrate them, and we plugged in his old pedals.
He was driving around with one hand on the wheel and pushing the accel and brake with his other hand. So not a true test, but the wheel is functioning.

As far as no end stops, the problem went away after changing the endstop settings, saving to simucube and restarting drive. Thanks Mika you were correct on that one!

The iracing problems seem to go away from deleting the fanatec drivers and app, and joycalib in iRacing docs.
Thanks Beano and Brion you were correct.

Thanks for all your help!

Talk soon,
Joe