New SimuCube - No connection to Granity

Hi all, I’m having a lot of trouble connecting a brand new SimuCube to Granity and the SimuCube Config tool.
It was purchased through the initial Granity Devices IndieGoGo campaign. Up until now I’ve still been using my previous OSW build below.

Previous Setup
OSW Build with Ioni Pro
Large Mige 15015 Motor
5,000PPR encoder
Run via MMOS

New Setup
SimuCube with Ioni Pro HC
480W/720W Peak PSU upgrade
Large Mige 15015 Motor
Simtronix (Heidenhain) SinCos encoder
Run via SimuCube software

Steps so far …

  1. Disconnected old OSW build from PC, motor and power.
  2. Connected all SimuCube cables to PC, encoder.
  3. Powered on Simucube. Did not notice any driver installation or status change in Windows 10 devices.
  4. Made initial connection to Granity (latest release). Simucube had orange light flashing in sequence Short, Short, Short, Long.
  5. Loaded 15015_MAX_480w_48v_3600(64x).drc from this iRacing thread:
  6. Granity Status Notification said drive must be restarted so followed instructions.
  7. Disconnected Drive and powered down Simucube.
  8. Connected E-Stop and powered up Simucube. Orange flashes gone. Only constant green light remains.
  9. No change in Windows devices found. No listing to connect to drive in Granity either.

Device Manager connection for SimuCube

YouTube video I made of me running through the current state of the issue here.

Have tried to connect via Granity versions 1.9.0, 1.10.1, 1.10.2 and 1.14.1
Same result each time. No connection listed when searching correct SimpleMotion port.

And advice at this stage would be greatly appreciated.
Thank you!

Hi, follow my advice i provided in iRacing, it will get you going. You need to flash a boot loader via dfu to your SimuCube and then initiate a FW install.