New Pro 2 No Power when Plugged to Motor

Hi ,
Just received a Pro 2 . Powered up fine on first power up 2 days ago . Used it for 1min, shut it off went to bed with plans to setup a profile today.

Powered up fine , was working on a profile heard a beep , like a device disconnect notification from windows , didn’t think it was my motor , but when i saved my profile , software greyed out , I noticed the power supply light was not on anymore . Checked all connections including USB all good .

Took power supply and plugged into another outlet and light indicates has power . Disconnected plugged into motor first connected PSU again and no blue light . Disconnect from motor and blue light on psu lights up.

Have contacted my supplier , but curious what this might be . Ive only managed half a lap and really want to get things dialed in and get on track ….

Is USB connected, try different cable or port? It does need one to power up.


USB connected and tried different port. PSU refuses to power on when the cable to the motor is connected. Unconnected to motor I get the “pretty” blue light on PSU.

Please don’t connect power to the PSU and then to the Simucube 2. You can fry it this way.

Always connect everything to the Simucube/PC first before you plug in the PSU to the power supply from the apartment or house.

Also check out the constant high torque enabled feature. You have to agree to the security disclaimer, wait for the countdown to be finished. Then you can enable high torque always on

Hi ,

Yes i connected to motor and pc before plugging into AC. When i powered down i was careful to pull AC from wall first and when replugging i waited for capacitor to discharge fully .

On first power up everything was good. Was able to encage hi torque . It was 2nd power up when this happened.

Try with another usb cable like it was suggested

Tried with new and confirmed working usb cable direct to PC and new port and still have an expensive paper weight…

Did you make a support ticket already?

Waiting for my supplier “Advanced Sim Racing” to get back to me. I contacted them right away on Saturday, but have not had a response yet. Just sent 3rd e-mail…

I once had the connector to the power brick a bit loose. Can’t remember if the blue light was on, but didn’t work. Sorry, last idea. After that it’s only support left

Thanks , have contacted support…now admiring my new fancy “paperweight”

1 Like

Maybe you consider to step up a class and try to make it in light featherweight…:heart_hands: