Need help for DD Wheel. I can not get it to work


#1

Hello all,

I have a big problem. I can not get my DD wheel started.

I have the following components:

Small MiGE 130ST-M10010 (10000ppr encoder)

Argon Servo Drive with STM32F4DISCOVERY and Braking resistor

I have reloaded the following FW. (ArgonFWpackage2.1.0-simwheel-GCFW-9300.gdf)

That worked.

Then I set the following values ​​for the Mige in Granity. See picture 1 – 7

Then I started Mmos and set the following under Setup:

-PWM Mode = PWM & Dir

-PWM = 3.4 kHz

-Enable Force Led = unchecked

Encoder CPR = 40000

-Reverse encoder = unchecked

-Use Encoder Index = CHECKED

-Report Combined Pedals = unchecked

-The four remaining drop down selections all set to NONE

  • To save

  • "Reset"  No.

-Abort, stop

  • "FFB configuration": Default  Save; Eprom  Save

http://wewe-motorsport.de/8.JPG

  • Exit and switch off the system

  • Switch on the system again and wait until indexing ends

Turn the steering wheel until the blue light goes off

But the blue light keeps flashing on and on?

• Open the MMO’s, turn the steering wheel straight and center on “Steering”

• Then an offset value should actually be displayed under "turning range" and the steering wheel should work

But there is no offset value ???

Also it does not save the setup parameters in Mmos.

Then I got a tip I should not click in the setup of Mmos the hack at index score. When I do that and reboot the blue LED does not light up. And he keeps the setup settings in Mmos. (See pictures)

http://wewe-motorsport.de/11.JPG

But the steering wheel is not recognized or moved under Windows Game Controller.

When starting the steering wheel 1-2 moves a little to the left and right. Then it stops and makes a clear "click".

Do you know what could be the mistake here? I despair so slowly.

Many thanks in advance for your help.


#2

Looks like MMOS is having some trouble finding the index point on the encoder and fails to initialize becuase of this. So it won’t save any settings either. There is either a red or green “receptable” indicator in the bottom left of the user interface; if it is red, then there is no firmware running OR it has not initialized properly, so any changes and things you do, won’t have any effect.

Perhaps we have someone here that has more knowledge of how these early OSW systems worked - we don’t provide any official support for MMOS issues.


#3

Hallo,

The button is green.


#4

Hello Helmut,
i am not sure who put this build together, so we assume that all is working and only problem is that mmos doesnt find zero point (0 point of encoder). Until it doesnt, wheel movement will not work. It might only be that you having big offset

I would try this procedure:
-power on system and wait until phasing will complete.
-open mmos tool.
-turn wheel one full turn to the left and back to center and one full turn to the right and back to center
-than inside mmos main window: click save to default, click save to eprom and click load from eprom. You can repeat clicks “load” and “save” while dropdown will be at “eprom”. That should make “offset number” to appear.

If it will not appear, connect with Granity and observe “position feedback” value (under testing tab) while you move your wheel. Those numbers should change according to encoder of servo motor. For example one full turn with wheel (360˘) should be seen as 40000 numbers change (40000cpr=10000ppr encoder)


#5

First things first. 2.1.3 https://granitedevices.com/wiki/Argon_firmware_releases doesn’t flash ?

Your settings need changes.

CIS = not checked
CED = checked

MCC = 6,250 A
MMC = 12,860 A
MR = 2,744
ML = 8,601

Change FOC = Maximum

Don’t forget to apply settings

i ll recheck if you need something else in granity. Make sure the estop is released

MMOS , Encoder Index must be set to checked , but your granity settings must be correct in order for the wheel to work.


#6

Hi Tomo
The numbers will not change when I move the Wheel. The number stand always at 0 r/s

means that the encoder is broken?


#7

it could also be a wiring problem


#8

Might be so. Or the encoder is loose on the shaft, its been known to happen as well.


#9

I would say extremely unlikely for broken encoder. Much more chance to be something on wiring inside your build, DB15 wiring on encoder cable, discovery etc. You can check if encoder isnt loose, like Mika mentioned, just to be sure…